summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Levy2015-08-09 23:03:37 -0300
committerDan Levy2015-08-09 23:03:37 -0300
commitd0bdbec01b95f6d56aa2a79b05abd1bc5af68840 (patch)
tree2794e28f013c3747f9a6e8af7cea882a0afdae34
downloadaur-d0bdbec01b95f6d56aa2a79b05abd1bc5af68840.tar.gz
Migrated to git!
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD48
-rw-r--r--starsector.desktop9
-rw-r--r--starsector.install28
-rw-r--r--starsector.sh33
5 files changed, 143 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0062b8be0d08
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = starsector
+ pkgdesc = A single-player sandbox style space role-playing game with strategic elements.
+ pkgver = 0.65.2a_RC2
+ pkgrel = 1
+ url = http://fractalsoftworks.com/
+ install = starsector.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = java-runtime
+ depends = openal
+ depends = bash
+ depends = desktop-file-utils
+ replaces = starfarer
+ source = http://s3.amazonaws.com/fractalsoftworks/starsector/starsector_linux-0.65.2a-RC2.zip
+ source = starsector.pdf::http://www.fractalsoftworks.com/starfarer/docs/StarfarerManual.pdf
+ source = starsector.sh
+ source = starsector.desktop
+ sha256sums = 762d2f451d0a6a147e120bc319b3651ee9464b9662a3c9d76faadc4344047c57
+ sha256sums = 0d9a2382e1c15e3d471b88eb3770c68f5dd93edc81710e511fd892def9f2ab16
+ sha256sums = d0588ccc3eefe399d764144246718344ff5603396130028a798fc1609d4d0286
+ sha256sums = becc92483d9599672b75d8b00216a64dd8fda38cfcfccd8e735238aa0ce6d8b6
+
+pkgname = starsector
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10a1ac721a94
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Erdbeerkaese <erbeerkaese dot arch at gmail dot com>
+
+pkgname=starsector
+pkgver=0.65.2a_RC2
+pkgrel=1
+pkgdesc="A single-player sandbox style space role-playing game with strategic elements."
+arch=('i686' 'x86_64')
+url="http://fractalsoftworks.com/"
+license=('custom')
+depends=('java-runtime' 'openal' 'bash' 'desktop-file-utils')
+install='starsector.install'
+replaces=('starfarer')
+source=(
+http://s3.amazonaws.com/fractalsoftworks/starsector/starsector_linux-${pkgver//_/-}.zip
+${pkgname}.pdf::http://www.fractalsoftworks.com/starfarer/docs/StarfarerManual.pdf
+starsector.sh
+starsector.desktop)
+sha256sums=('762d2f451d0a6a147e120bc319b3651ee9464b9662a3c9d76faadc4344047c57'
+ '0d9a2382e1c15e3d471b88eb3770c68f5dd93edc81710e511fd892def9f2ab16'
+ 'd0588ccc3eefe399d764144246718344ff5603396130028a798fc1609d4d0286'
+ 'becc92483d9599672b75d8b00216a64dd8fda38cfcfccd8e735238aa0ce6d8b6')
+package() {
+ install -d "$pkgdir/usr/share/$pkgname" \
+ "$pkgdir/usr/share/doc/$pkgname" \
+ "$pkgdir/usr/share/applications" \
+ "$pkgdir/usr/share/java/$pkgname" \
+ "$pkgdir/usr/lib/$pkgname"
+
+ cd "$srcdir"
+ install -Dm644 "${pkgname}.pdf" "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm755 "${pkgname}.sh" "$pkgdir/usr/bin/$pkgname"
+ install -Dm644 "${pkgname}.desktop" "$pkgdir/usr/share/applications"
+
+ cd "$srcdir/$pkgname"
+
+ install -Dm644 *.jar "$pkgdir/usr/share/java/$pkgname"
+ install -Dm644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ if [[ "$CARCH" == x86_64 ]]; then
+ install -Dm644 native/linux/*64.so "$pkgdir/usr/lib/$pkgname/"
+ else
+ install -Dm644 native/linux/*[!"64"].so "$pkgdir/usr/lib/$pkgname/"
+ fi
+
+ find data graphics sounds -type f -print | xargs chmod 644
+ cp -R data graphics sounds "$pkgdir/usr/share/$pkgname/"
+}
+# vim:set ts=2 sw=2 et:
diff --git a/starsector.desktop b/starsector.desktop
new file mode 100644
index 000000000000..8e763b43ea1b
--- /dev/null
+++ b/starsector.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Starsector
+GenericName=Starsector
+Comment=A single-player sandbox style space role-playing game with strategic elements
+Exec=starsector
+Icon=/usr/share/starsector/graphics/ui/s_icon64.png
+Terminal=false
+Type=Application
+Categories=Game;
diff --git a/starsector.install b/starsector.install
new file mode 100644
index 000000000000..76c368ccda1b
--- /dev/null
+++ b/starsector.install
@@ -0,0 +1,28 @@
+## arg 1: the new package version
+post_install() {
+ update-desktop-database -q
+ echo ">>> PACKAGE NOTES"
+ echo ">>> --------------"
+ echo ">>> This is the full version of the game, you need a serial key to play it."
+ echo ">>> You can buy a serial key at http://fractalsoftworks.com/preorder/"
+ echo ">>> for 10$ (while in alpha)."
+ echo ""
+ echo ">>> RELEASE NOTES:"
+ echo ">>> --------------"
+ echo ">>> http://fractalsoftworks.com/forum/index.php?topic=7279.0"
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+post_upgrade() {
+ update-desktop-database -q
+ echo ">>> RELEASE NOTES:"
+ echo ">>> --------------"
+ echo ">>> http://fractalsoftworks.com/forum/index.php?topic=7279.0"
+}
+
+post_remove() {
+ update-desktop-database -q
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/starsector.sh b/starsector.sh
new file mode 100644
index 000000000000..2f85ba14287d
--- /dev/null
+++ b/starsector.sh
@@ -0,0 +1,33 @@
+#!/bin/bash
+
+# fix for users of special IM modules
+unset XMODIFIERS GTK_IM_MODULE QT_IM_MODULE
+unset CLASSPATH
+
+BASEPATH=~/.starsector
+SAVEPATH=${BASEPATH}/saves
+MODPATH=${BASEPATH}/mods
+SCRPATH=${BASEPATH}/screenshots
+LOGPATH=${BASEPATH}/
+
+[ -d ${BASEPATH} ] || mkdir ${BASEPATH}
+[ -d ${SAVEPATH} ] || mkdir ${SAVEPATH}
+[ -d ${MODPATH} ] || mkdir ${MODPATH}
+[ -d ${SCRPATH} ] || mkdir ${SCRPATH}
+
+for jarfile in /usr/share/java/starsector/*.jar ; do
+ CLASSPATH=${CLASSPATH}:${jarfile}
+done
+
+cd /usr/share/starsector
+exec java -server \
+ -XX:CompilerThreadPriority=1 \
+ -XX:+CompilerThreadHintNoPreempt \
+ -Djava.library.path=/usr/lib/starsector \
+ -Xms512m -Xmx1024m -classpath ${CLASSPATH} \
+ -Dcom.fs.starfarer.settings.paths.saves=${SAVEPATH} \
+ -Dcom.fs.starfarer.settings.paths.screenshots=${SCRPATH} \
+ -Dcom.fs.starfarer.settings.paths.mods=${MODPATH} \
+ -Dcom.fs.starfarer.settings.paths.logs=${LOGPATH} \
+ com.fs.starfarer.StarfarerLauncher
+# vim:set ts=2 sw=2 et: