summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchipbuster2019-08-23 11:38:47 -0500
committerchipbuster2019-08-23 12:19:02 -0500
commit478afba175876d50bbc7429e2d4089fb25d65f81 (patch)
treecf616f4bd6ea1945e72565778a612e23bcfb5eea
downloadaur-478afba175876d50bbc7429e2d4089fb25d65f81.tar.gz
Initial commit at v0.12.2
-rw-r--r--.SRCINFO16
-rw-r--r--.gitconfig5
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD23
4 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd08328838b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = starship-bin
+ pkgdesc = The cross-shell prompt for astronauts
+ pkgver = 0.12.2
+ pkgrel = 1
+ url = https://starship.rs/
+ arch = x86_64
+ license = ISC
+ depends = openssl
+ depends = zlib
+ provides = starship
+ conflicts = starship
+ source = https://github.com/starship/starship/releases/download/v0.12.2/starship-v0.12.2-x86_64-unknown-linux-gnu.tar.gz
+ sha256sums = a491a28eb6d8baf70fe7576c60ac7eb2d243ad7e94575f95bba0aeb7c9e0f4ca
+
+pkgname = starship-bin
+
diff --git a/.gitconfig b/.gitconfig
new file mode 100644
index 000000000000..3b43f020b87a
--- /dev/null
+++ b/.gitconfig
@@ -0,0 +1,5 @@
+[user]
+ email = kevins05@gmail.com
+ name = chipbuster
+[push]
+ default = simple
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b70994daa21
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Kevin Song <kevin dot s05 at gmail dot com>
+
+pkgname='starship-bin'
+pkgdesc='The cross-shell prompt for astronauts'
+pkgver='0.12.2'
+pkgrel='1'
+arch=('x86_64')
+url='https://starship.rs/'
+license=('ISC')
+depends=('openssl' 'zlib')
+makedepends=()
+checkdepends=()
+provides=('starship')
+conflicts=('starship')
+source=("https://github.com/starship/starship/releases/download/v${pkgver}/starship-v${pkgver}-x86_64-unknown-linux-gnu.tar.gz")
+sha256sums=('a491a28eb6d8baf70fe7576c60ac7eb2d243ad7e94575f95bba0aeb7c9e0f4ca')
+PKGEXT='.pkg.tar.gz'
+
+package() {
+ cd "x86_64-unknown-linux-gnu"
+ install -Dm755 "starship" "$pkgdir/usr/bin/starship"
+# install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}