summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwcasanova2021-02-14 22:01:59 -0300
committerwcasanova2021-02-14 22:01:59 -0300
commitc24900674b9ca8892ab84abd2b8d0ff628844af1 (patch)
tree52705ebcdabd6fcbb053395c3ba37579b36f5a7c
parent3dc67ad5b5b2cdd2aa9bcfa74af8d1b36caf8442 (diff)
downloadaur-c24900674b9ca8892ab84abd2b8d0ff628844af1.tar.gz
add provides, update build
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD22
2 files changed, 13 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 91e9b78ecd1a..fe756ed8b3ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = starship-git
pkgdesc = The cross-shell prompt for astronauts
- pkgver = 0.27.0.580.g1de281e
+ pkgver = 0.50.0.1370.gd0951db3
pkgrel = 1
url = https://github.com/starship/starship
arch = x86_64
@@ -10,6 +10,7 @@ pkgbase = starship-git
makedepends = git
optdepends = powerline-fonts: powerline symbols for terminals
optdepends = nerd-fonts-complete: popular collections such as Font Awesome & fonts such as Hack
+ provides = starship
conflicts = starship
source = starship::git+https://github.com/starship/starship.git
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 39e6aac423ec..454345293487 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
-# Maintainer: Walter C <bitlord@disroot.org>
+# Maintainer: Walter - "d2Nhc2Fub3ZhQGRpc3Jvb3Qub3JnCg==" - use base64 -d
pkgname="starship-git"
_pkgname="starship"
-pkgver=0.27.0.580.g1de281e
+pkgver=0.50.0.1370.gd0951db3
pkgrel=1
pkgdesc="The cross-shell prompt for astronauts"
arch=("x86_64")
@@ -12,7 +12,7 @@ depends=()
optdepends=('powerline-fonts: powerline symbols for terminals'
'nerd-fonts-complete: popular collections such as Font Awesome & fonts such as Hack')
makedepends=("rust" "cargo" "git")
-provides=()
+provides=("starship")
conflicts=("starship")
source=("$_pkgname::git+https://github.com/starship/starship.git")
sha256sums=("SKIP")
@@ -22,15 +22,15 @@ pkgver() {
echo "$(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2).$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
}
-build() {
- cd $_pkgname
- cargo build --release --locked
-}
-
+ build() {
+ cd $_pkgname
+ cargo build --release --locked --all-features --target-dir=target
+ }
+
check() {
- cd $_pkgname
- cargo test --locked
-}
+ cd $_pkgname
+ cargo test --release --locked --target-dir=target
+ }
package() {
cd "$srcdir/$_pkgname"