summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2017-11-02 22:22:04 -0600
committerBrian Bidulock2017-11-02 22:22:04 -0600
commite63e9a25a9d0a449c4534e6241ebf25d1ba36214 (patch)
tree5932005fc8d91011cc46af74fd6b7b25bf745d2a
downloadaur-e63e9a25a9d0a449c4534e6241ebf25d1ba36214.tar.gz
initial version
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD41
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c992b04e39f7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = startup-notification-git
+ pkgdesc = Monitor and display application startup
+ pkgver = 0.12.r9.g5c1a52c
+ pkgrel = 1
+ url = https://www.freedesktop.org
+ arch = i686
+ arch = x86_64
+ license = LGPL
+ makedepends = git
+ depends = libx11
+ depends = xcb-util
+ provides = startup-notification=0.12
+ conflicts = startup-notification
+ source = startup-notification-git::git+https://github.com/bbidulock/startup-notification.git
+ sha256sums = SKIP
+
+pkgname = startup-notification-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36bcdce1c91e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# $Id$
+# Maintainer: Jan de Groot <jgc@archlinux.org>
+# Contributor: dorphell <dorphell@archlinux.org>
+
+pkgname=startup-notification-git
+_pkgname=startup-notification
+pkgver=0.12.r9.g5c1a52c
+pkgrel=1
+pkgdesc="Monitor and display application startup"
+arch=(i686 x86_64)
+license=('LGPL')
+depends=('libx11' 'xcb-util')
+makedepends=('git')
+provides=($_pkgname=0.12)
+conflicts=($_pkgname)
+url="https://www.freedesktop.org"
+source=(${pkgname}::git+https://anongit.freedesktop.org/git/startup-notification.git)
+source=(${pkgname}::git+https://github.com/bbidulock/startup-notification.git)
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed -r 's/^[^0-9]*//;s/([^-]*-g)/r\1/;s/[-_]/./g'
+}
+
+prepare() {
+ cd ${pkgname}
+ autoreconf -fiv
+}
+
+build() {
+ cd ${pkgname}
+ ./configure --prefix=/usr --localstatedir=/var --sysconfdir=/etc
+ sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ make
+}
+
+package() {
+ cd ${pkgname}
+ make DESTDIR="${pkgdir}" install
+}