summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Ray Mahardhika2018-06-25 06:21:42 +0700
committerMario Ray Mahardhika2018-06-25 06:21:42 +0700
commit7a7c04d7ed048472fcb1e5c6218b3d73c1340c75 (patch)
tree0f7ce17f06f89d2d4faab16eb790b899fc8f3712
parent27c10a3b780be128eb70fe49a0c5f98bdbccb913 (diff)
downloadaur-7a7c04d7ed048472fcb1e5c6218b3d73c1340c75.tar.gz
Updated to 3.0.0 thanks to @abend
Removal of unnecessary install (icon & desktop cache update now done automatically) and shell script
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD52
-rw-r--r--staruml.install4
-rwxr-xr-xstaruml.sh1
4 files changed, 29 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 042069518429..1fa6c6868e5f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,24 @@
# Generated by mksrcinfo v8
-# Sun Jan 7 20:21:31 UTC 2018
+# Sun Jun 24 23:17:57 UTC 2018
pkgbase = staruml
pkgdesc = A sophisticated software modeler
- pkgver = 2.8.1
+ pkgver = 3.0.0
pkgrel = 1
url = http://staruml.io/
- install = staruml.install
arch = i686
arch = x86_64
license = custom:staruml
- depends = nodejs
- depends = gnuplot
- depends = libgcrypt15
- depends = nss
depends = gconf
- depends = libudev0-shim
- source = staruml.sh
- md5sums = 9e14e38e0b2054353eab13e9f028bd74
- source_i686 = http://staruml.io/download/release/v2.8.1/StarUML-v2.8.1-32-bit.deb
- md5sums_i686 = 30c336ae9ba144e1e7f74e413bd534f0
- source_x86_64 = http://staruml.io/download/release/v2.8.1/StarUML-v2.8.1-64-bit.deb
- md5sums_x86_64 = fa8908a0c68200fd57511ea78d4bbd9f
+ depends = libxss
+ depends = libxtst
+ depends = nss
+ depends = alsa-lib
+ depends = gtk2
+ noextract = staruml-3.0.0-.AppImage
+ source_i686 = staruml-3.0.0-.AppImage::http://staruml.io/download/releases/StarUML-3.0.0-i386.AppImage
+ sha256sums_i686 = be5c4d01386e6c853a37e3b13129f32424a8f5975f65c55f505674329fa5675b
+ source_x86_64 = staruml-3.0.0-.AppImage::http://staruml.io/download/releases/StarUML-3.0.0-x86_64.AppImage
+ sha256sums_x86_64 = ddfe85e674bd292aeb43f9575a07ca703d7f4ffdb071f6452a537e30fb65faec
pkgname = staruml
diff --git a/PKGBUILD b/PKGBUILD
index f74d4ec99129..acded983cd8c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,30 @@
# Maintainer: Mario Ray Mahardhika <leledumbo_cool@yahoo.co.id>
pkgname=staruml
-pkgver=2.8.1
+pkgver=3.0.0
pkgrel=1
pkgdesc="A sophisticated software modeler"
arch=('i686' 'x86_64')
url="http://staruml.io/"
license=('custom:staruml')
-depends=('nodejs' 'gnuplot' 'libgcrypt15' 'nss' 'gconf' 'libudev0-shim')
-source=('staruml.sh')
-source_i686=("http://staruml.io/download/release/v$pkgver/StarUML-v$pkgver-32-bit.deb")
-source_x86_64=("http://staruml.io/download/release/v$pkgver/StarUML-v$pkgver-64-bit.deb")
-md5sums=('9e14e38e0b2054353eab13e9f028bd74')
-md5sums_i686=('30c336ae9ba144e1e7f74e413bd534f0')
-md5sums_x86_64=('fa8908a0c68200fd57511ea78d4bbd9f')
-install=${pkgname}.install
+depends=('gconf' 'libxss' 'libxtst' 'nss' 'alsa-lib' 'gtk2')
+source_i686=("$pkgname-$pkgver-$CARCH.AppImage::http://staruml.io/download/releases/StarUML-$pkgver-i386.AppImage")
+source_x86_64=("$pkgname-$pkgver-$CARCH.AppImage::http://staruml.io/download/releases/StarUML-$pkgver-x86_64.AppImage")
+noextract=("$pkgname-$pkgver-$CARCH.AppImage")
+sha256sums_i686=('be5c4d01386e6c853a37e3b13129f32424a8f5975f65c55f505674329fa5675b')
+sha256sums_x86_64=('ddfe85e674bd292aeb43f9575a07ca703d7f4ffdb071f6452a537e30fb65faec')
prepare() {
- rm control.tar.gz
- rm debian-binary
- tar xJf data.tar.xz
+ chmod +x $pkgname-$pkgver-$CARCH.AppImage
+ ./$pkgname-$pkgver-$CARCH.AppImage --appimage-extract
}
package() {
- # the original symlink is wrong, still pointing to the original brackets binary
- ln -fs /opt/staruml/StarUML $srcdir/usr/bin/staruml
-
- # add the directory to PATH
- mkdir -p $pkgdir/etc/profile.d
- cp -f $srcdir/staruml.sh $pkgdir/etc/profile.d/
-
- # move icons to the correct folder
- for size in 32 48 128 256
- do
- dir=$pkgdir/usr/share/icons/hicolor/${size}x${size}
- mkdir -p $dir
- mv $srcdir/opt/staruml/appshell${size}.png $dir/
- done
-
- # and the desktop entry, too
- dir=$pkgdir/usr/share/applications
- mkdir -p $dir
- mv $srcdir/opt/staruml/staruml.desktop $dir/
-
- # finally, the directories
- cp -Rfp $srcdir/opt $srcdir/usr $pkgdir/
+ mkdir -p $pkgdir/opt/${pkgname} $pkgdir/usr/share/applications $pkgdir/usr/bin/
+ cp -Rf $srcdir/squashfs-root/app/* $pkgdir/opt/${pkgname}
+ cp -Rf $srcdir/squashfs-root/usr/share/* $pkgdir/usr/share
+ cp -fp $srcdir/squashfs-root/staruml.desktop $pkgdir/usr/share/applications
+ sed -i 's/AppRun/staruml/g' $pkgdir/usr/share/applications/staruml.desktop
+ chmod -R 755 $pkgdir
+ ln -fs /opt/staruml/staruml $pkgdir/usr/bin/staruml
+ ln -fs /usr/share/icons/hicolor/512x512/apps/staruml.png $pkgdir/opt/${pkgname}/staruml.png
}
-
diff --git a/staruml.install b/staruml.install
deleted file mode 100644
index 368d926cf29a..000000000000
--- a/staruml.install
+++ /dev/null
@@ -1,4 +0,0 @@
-post_install() {
- gtk-update-icon-cache -f /usr/share/icons/hicolor
- update-desktop-database -q
-}
diff --git a/staruml.sh b/staruml.sh
deleted file mode 100755
index dc9148e3bd52..000000000000
--- a/staruml.sh
+++ /dev/null
@@ -1 +0,0 @@
-export PATH=$PATH:/opt/staruml/