summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSumner Evans2019-01-18 13:58:01 -0700
committerSumner Evans2019-01-18 13:58:01 -0700
commit26aa6bd0a035d9662d05938bdede0b899588da13 (patch)
treebc8c3f1eab1264e775abaaa84e36dfdaa6722d4a
parentde4204110cbde9870886d6b1f0e9061c0cc585bc (diff)
downloadaur-26aa6bd0a035d9662d05938bdede0b899588da13.tar.gz
Updated to version 2.0.0
-rw-r--r--.SRCINFO10
-rw-r--r--Makefile8
-rw-r--r--PKGBUILD19
-rwxr-xr-xupdate.sh67
4 files changed, 92 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db3b6335d439..54cc4f578ce1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = statcode
- pkgdesc = Like man pages, but for HTTP status codes
- pkgver = 1.0.0
- pkgrel = 4
+ pkgdesc = Man pages for HTTP status codes
+ pkgver = 2.0.0
+ pkgrel = 1
url = https://github.com/shobrook/statcode
arch = any
license = MIT
@@ -9,8 +9,8 @@ pkgbase = statcode
depends = python
depends = python-urwid
depends = python-yaml
- source = https://files.pythonhosted.org/packages/source/s/statcode/statcode-1.0.0.tar.gz
- sha256sums = 973bcf53ef9beedbb6d334dea5536af28b4fd02b5a2ed4b91cf2a256860dabe3
+ source = https://files.pythonhosted.org/packages/source/s/statcode/statcode-2.0.0.tar.gz
+ sha256sums = cc22f598c2fb6e585d8718010c0e9d24716738ff64f0490830ec0c121372d58e
pkgname = statcode
depends = python
diff --git a/Makefile b/Makefile
index cd3176fb3e1c..d29e5ed881c1 100644
--- a/Makefile
+++ b/Makefile
@@ -1,2 +1,10 @@
+PROJECT_NAME=tracktime
+
all:
makepkg --printsrcinfo > .SRCINFO
+
+clean:
+ rm -rf *-any.pkg.tar
+ rm -rf *.tar.gz
+ rm -rf dist
+ rm -rf ${PROJECT_NAME}
diff --git a/PKGBUILD b/PKGBUILD
index 5977947ddd5c..f8f5fe52efb8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,16 +3,21 @@
pkgbase=('statcode')
pkgname=('statcode')
_module='statcode'
-pkgver='1.0.0'
-pkgrel=4
-pkgdesc="Like man pages, but for HTTP status codes"
-url="https://github.com/shobrook/statcode"
-depends=('python' 'python-urwid' 'python-yaml')
+pkgver='2.0.0'
+pkgrel=1
+pkgdesc='Man pages for HTTP status codes'
+url='https://github.com/shobrook/statcode'
+depends=(
+ 'python'
+ 'python-urwid'
+ 'python-yaml'
+)
makedepends=('python-setuptools')
license=('MIT')
arch=('any')
-source=("https://files.pythonhosted.org/packages/source/s/statcode/statcode-${pkgver}.tar.gz")
-sha256sums=('973bcf53ef9beedbb6d334dea5536af28b4fd02b5a2ed4b91cf2a256860dabe3')
+source=('https://files.pythonhosted.org/packages/source/s/statcode/statcode-2.0.0.tar.gz')
+sha256sums=('cc22f598c2fb6e585d8718010c0e9d24716738ff64f0490830ec0c121372d58e')
+
build() {
cd "${srcdir}/${_module}-${pkgver}"
diff --git a/update.sh b/update.sh
new file mode 100755
index 000000000000..2d0635c22d9a
--- /dev/null
+++ b/update.sh
@@ -0,0 +1,67 @@
+#! /bin/sh
+
+AUR_NAME=statcode
+PROJ_NAME=statcode
+DESCRIPTION="Man pages for HTTP status codes"
+URL=https://github.com/shobrook/statcode
+DEPENDS=(
+ python-urwid
+ python-yaml
+)
+LICENSE='MIT'
+ADDITIONAL=
+
+if [[ $# == 0 ]]; then
+ echo 'Usage: ./update.sh VERSION_NUMBER'
+ exit 1
+fi
+
+src=https://files.pythonhosted.org/packages/source/${PROJ_NAME:0:1}/${PROJ_NAME}/${PROJ_NAME}-$1.tar.gz
+
+# Get the sha256sum sum of the package.
+mkdir -p dist
+pushd dist
+wget $src
+sha=$(sha256sum "${PROJ_NAME}-$1.tar.gz" | cut -d ' ' -f 1)
+popd
+
+echo "# Maintainer: Sumner Evans <sumner.evans98 at gmail dot com>
+
+pkgbase=('${AUR_NAME}')
+pkgname=('${AUR_NAME}')
+_module='${PROJ_NAME}'
+pkgver='$1'
+pkgrel=1
+pkgdesc='${DESCRIPTION}'
+url='${URL}'
+depends=(
+ 'python'" > PKGBUILD
+
+# Include the dependencies.
+for d in ${DEPENDS[*]}; do
+ echo " '$d'" >> PKGBUILD
+done
+
+echo ")
+makedepends=('python-setuptools')
+license=('${LICENSE}')
+arch=('any')
+source=('${src}')
+sha256sums=('${sha}')
+${ADDITIONAL}
+
+build() {
+ cd \"\${srcdir}/\${_module}-\${pkgver}\"
+ python setup.py build
+}
+
+package() {
+ depends+=()
+ cd \"\${srcdir}/\${_module}-\${pkgver}\"
+ python setup.py install --root=\"\${pkgdir}\" --optimize=1 --skip-build
+}" >> PKGBUILD
+
+make
+
+# Test
+makepkg -f