summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfelics@felics-tablet2016-06-27 10:15:42 +0200
committerfelics@felics-tablet2016-06-27 10:15:42 +0200
commit6add6f1c9a9198a0ff5a4677633b04604211d00e (patch)
tree7a8e726d0da67bab18b680fd646a377c377e8a3c
downloadaur-6add6f1c9a9198a0ff5a4677633b04604211d00e.tar.gz
Initial commit.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD62
2 files changed, 78 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7f078fad734
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = statifier
+ pkgdesc = A tool for creating portable, self-containing Linux executables: Creates from dynamically linked executables and all it's libraries one file. This file can be copied and run on another machine without need to drag all it's libraries.
+ pkgver = 1.7.4
+ pkgrel = 1
+ url = http://statifier.sourceforge.net/
+ arch = i386
+ arch = i486
+ arch = i586
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ source = statifier-1.7.4.tar.gz::https://sourceforge.net/projects/statifier/files/statifier/1.7.4/statifier-1.7.4.tar.gz/download
+ sha256sums = c8a758ee1f3604d1c6fa755e2422ac4e741008536c9065508050da69149d9f0e
+
+pkgname = statifier
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e845514e9311
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: dreieck
+
+_pkgname=statifier
+pkgname="${_pkgname}"
+_pkgver=1.7.4
+# epoch=0
+pkgver="${_pkgver}"
+pkgrel=1
+pkgdesc="A tool for creating portable, self-containing Linux executables: Creates from dynamically linked executables and all it's libraries one file. This file can be copied and run on another machine without need to drag all it's libraries."
+arch=('i386' 'i486' 'i586' 'i686' 'x86_64')
+url="http://statifier.sourceforge.net/"
+license=('GPL2')
+# depends=('zlib' 'gnutls' 'libgcrypt')
+
+provides=(
+)
+replaces=(
+)
+conflicts=(
+)
+
+backup=(
+)
+
+# install="${_pkgname}.install"
+
+source=(
+ "statifier-${_pkgver}.tar.gz::https://sourceforge.net/projects/statifier/files/statifier/${_pkgver}/statifier-${_pkgver}.tar.gz/download"
+)
+
+sha256sums=(
+ "c8a758ee1f3604d1c6fa755e2422ac4e741008536c9065508050da69149d9f0e"
+)
+
+# pkgver() {
+# _unpackeddir="${srcdir}/${_pkgname}-${_pkgver}"
+# cat "${_unpackeddir}/VERSION"
+# }
+
+build() {
+ _unpackeddir="${srcdir}/${_pkgname}-${_pkgver}"
+ cd "${_unpackeddir}"
+
+ make
+}
+
+package() {
+ _unpackeddir="${srcdir}/${_pkgname}-${_pkgver}"
+ cd "${_unpackeddir}"
+
+ make DESTDIR="${pkgdir}" install
+
+ _docdir="${pkgdir}/usr/share/doc/${_pkgname}"
+
+ for _doc in AUTHORS ChangeLog FAQ INSTALL LICENSE NEWS README RELEASE THANKS TODO VERSION; do
+ install -Dpv -m 644 "${_unpackeddir}/${_doc}" "${_docdir}/general/${_doc}"
+ done
+
+ install -dv -m 755 "${_docdir}/detailed/"
+ cp -av "${_unpackeddir}/doc"/* "${_docdir}/detailed/"
+
+}