summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122021-05-29 09:34:52 +0200
committerwillemw122021-05-29 09:34:52 +0200
commit5753a57b3ab83bfdc9490f2c28c2554f750bcd18 (patch)
treebcf9ed9b6d0632734bd9edeecc0ebdcccb69d251
parent5901b825df5beaca1a16e0957e7b1b7588003bb5 (diff)
downloadaur-5753a57b3ab83bfdc9490f2c28c2554f750bcd18.tar.gz
0.0.4.post1 (unreleased/untagged)
Switch to Python 3
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD13
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffe3b1e4147f..68e533dc10a1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = statnot
pkgdesc = Notification daemon for lightweight window managers
- pkgver = 0.0.4
- pkgrel = 4
+ pkgver = 0.0.4.post1
+ pkgrel = 1
url = https://github.com/halhen/statnot
arch = x86_64
license = GPL
- depends = pygtk
- depends = python2-dbus
+ depends = gtk3
+ depends = python-dbus
+ depends = python-gobject
optdepends = libnotify: send notifications to statnot
optdepends = xorg-xsetroot: default configuration calls xsetroot
- source = https://github.com/halhen/statnot/archive/0.0.4.tar.gz
- md5sums = 73b74044b7aec19ab2483d5bac04eb8e
+ source = statnot-0.0.4.post1::git+https://github.com/halhen/statnot.git#commit=d70982eb5d86e7849295b634721a74a433fcb532
+ md5sums = SKIP
pkgname = statnot
diff --git a/PKGBUILD b/PKGBUILD
index 61fa3f994211..5510bd7e7da9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,22 @@
# Contributor: halhen <halhen at k2h dot se>
pkgname=statnot
-pkgver=0.0.4
-pkgrel=4
+pkgver=0.0.4.post1
+pkgrel=1
pkgdesc="Notification daemon for lightweight window managers"
arch=('x86_64')
+#url="http://www.k2h.se/code/"
url="https://github.com/halhen/statnot"
license=('GPL')
-depends=('pygtk' 'python2-dbus')
+depends=('gtk3' 'python-dbus' 'python-gobject')
optdepends=('libnotify: send notifications to statnot'
'xorg-xsetroot: default configuration calls xsetroot')
-source=("$url/archive/$pkgver.tar.gz")
-md5sums=('73b74044b7aec19ab2483d5bac04eb8e')
+#source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+source=($pkgname-$pkgver::git+$url.git#commit=d70982eb5d86e7849295b634721a74a433fcb532)
+md5sums=('SKIP')
package() {
cd $pkgname-$pkgver
- sed -i '1 s/python$/python2/' statnot
make DESTDIR="$pkgdir" install
}