summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdrián Pérez de Castro2015-12-17 16:37:30 +0200
committerAdrián Pérez de Castro2015-12-17 16:37:30 +0200
commitf6cc92064df35fe487e7051870f05ae4f8ebf16a (patch)
tree5b2578da3d77568ddb367b64c9e00d68ae1e1162
downloadaur-f6cc92064df35fe487e7051870f05ae4f8ebf16a.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD39
-rw-r--r--statsite.conf.example22
-rw-r--r--statsite.service12
4 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2e8632834a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+# Generated by mksrcinfo v8
+# Thu Dec 17 14:37:20 UTC 2015
+pkgbase = statsite
+ pkgdesc = A C implementation of StatsD
+ pkgver = 0.7.1
+ pkgrel = 1
+ url = http://armon.github.io/statsite
+ arch = x86_64
+ arch = arm
+ arch = i686
+ license = custom:BSD
+ makedepends = scons
+ depends = glibc
+ optdepends = python: InfluxDB, Graphite, Ganglia, and Librato sinks
+ optdepends = ruby: JSON/YAML sink
+ optdepends = nodejs: OpenTSDB sink
+ optdepends = bash: Cloudwatch sink
+ optdepends = aws-cli: Cloudwatch sink
+ source = https://github.com/armon/statsite/archive/v0.7.1.tar.gz
+ source = statsite.conf.example
+ source = statsite.service
+ sha512sums = c51db23002bfdcebea4a3a7276cb4012b881b5efc2b79e39b571cee9bcdcc3f5f76edb42c28971cd6f0534ca02ce216c4eadd06df3d25e23543ff1759a4fbd29
+ sha512sums = 78d01b634ac1d1831a9ee08318bee078e729ba3c725b80a6189830e7bedc57e06300c35843aa41106cbfb1290ad6fe30d24139563627399b83cd2cba479caf14
+ sha512sums = 5c5d3735ff6acab17d6ff9a5b0ab473e868a84d00dd19a1171322fc0b1ffdba789e56ae387b41aed455ab4db3c19c9b0527ad552f68a9827318f004e6bcdeafe
+
+pkgname = statsite
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2240b9711e2c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+pkgname='statsite'
+pkgdesc='A C implementation of StatsD'
+pkgver='0.7.1'
+pkgrel='1'
+url='http://armon.github.io/statsite'
+license='custom:BSD'
+makedepends=('scons')
+depends=('glibc')
+optdepends=('python: InfluxDB, Graphite, Ganglia, and Librato sinks'
+ 'ruby: JSON/YAML sink'
+ 'nodejs: OpenTSDB sink'
+ 'bash: Cloudwatch sink'
+ 'aws-cli: Cloudwatch sink')
+arch=('x86_64' 'arm' 'i686')
+source=("https://github.com/armon/statsite/archive/v${pkgver}.tar.gz"
+ statsite.conf.example
+ statsite.service)
+sha512sums=('c51db23002bfdcebea4a3a7276cb4012b881b5efc2b79e39b571cee9bcdcc3f5f76edb42c28971cd6f0534ca02ce216c4eadd06df3d25e23543ff1759a4fbd29'
+ '78d01b634ac1d1831a9ee08318bee078e729ba3c725b80a6189830e7bedc57e06300c35843aa41106cbfb1290ad6fe30d24139563627399b83cd2cba479caf14'
+ '5c5d3735ff6acab17d6ff9a5b0ab473e868a84d00dd19a1171322fc0b1ffdba789e56ae387b41aed455ab4db3c19c9b0527ad552f68a9827318f004e6bcdeafe')
+
+build () {
+ cd "${pkgname}-${pkgver}"
+ scons statsite
+}
+
+package () {
+ cd "${pkgname}-${pkgver}"
+ install -Dm755 statsite \
+ "${pkgdir}/usr/bin/statsite"
+ install -Dm644 LICENSE \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -dm755 "${pkgdir}/usr/libexec/statsite"
+ cp -a ./sinks "${pkgdir}/usr/libexec/statsite/"
+ install -Dm644 "${srcdir}/statsite.conf.example" \
+ "${pkgdir}/etc/statsite.conf.example"
+ install -Dm644 "${srcdir}/statsite.service" \
+ "${pkgdir}/usr/lib/systemd/system/statsite.service"
+}
diff --git a/statsite.conf.example b/statsite.conf.example
new file mode 100644
index 000000000000..6ab088eb2f42
--- /dev/null
+++ b/statsite.conf.example
@@ -0,0 +1,22 @@
+# Copy to /etc/statsite.conf and edit to suit your needs.
+
+[statsite]
+port=8125
+udp_port=8125
+log_level=INFO
+flush_interval=10
+timer_eps=0.01
+set_eps=0.02
+stream_cmd=python sinks/graphite.py localhost 2003
+
+[histogram_api]
+prefix=api
+min=0
+max=100
+width=5
+
+[histogram_default]
+prefix=
+min=0
+max=200
+width=20
diff --git a/statsite.service b/statsite.service
new file mode 100644
index 000000000000..616ab7aee1d8
--- /dev/null
+++ b/statsite.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Statsite daemon
+Documentation=https://github.com/armon/statsite
+After=network.target
+ConditionFileNotEmpty=/etc/statsite.conf
+
+[Service]
+User=nobody
+ExecStart=/usr/bin/statsite -f /etc/statsite.conf
+
+[Install]
+WantedBy=multi-user.target