summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2021-08-14 23:06:18 +0200
committerPellegrino Prevete2021-08-14 23:06:18 +0200
commit031ac5803ef03bbe0251b1eeabe99be6ae98e4f0 (patch)
tree7679be6ef1c963c00b6d6d0a3e6a69136b239013
downloadaur-031ac5803ef03bbe0251b1eeabe99be6ae98e4f0.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4a20aa908b2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = statusbar-alarm-dbus
+ pkgdesc = Plugin showing current time and alarm set
+ pkgver = 0.5.11
+ pkgrel = 1
+ url = https://github.com/maemo-leste/statusbar-alarm-dbus-api
+ arch = any
+ groups = maemo
+ license = LGPL
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = libtool
+ source = git+https://github.com/maemo-leste/statusbar-alarm-dbus-api.git#tag=0.5.11
+ sha256sums = SKIP
+
+pkgname = statusbar-alarm-dbus
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01efe71908c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Pellegrino Prevete <cGVsbGVncmlub3ByZXZldGVAZ21haWwuY29tCg== | base -d>
+# Contributor: Nikita Ukhrenkov <thekit@disroot.org>
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+
+pkgname=statusbar-alarm-dbus
+_pkgname=$pkgname-api
+pkgver=0.5.11
+pkgrel=1
+pkgdesc="Plugin showing current time and alarm set"
+url="https://github.com/maemo-leste/$_pkgname"
+arch=(any)
+license=(LGPL)
+makedepends=(autoconf automake libtool)
+checkdepends=()
+groups=(maemo)
+source=("git+$url.git#tag=$pkgver")
+sha256sums=('SKIP')
+
+prepare() {
+ cd $_pkgname
+ ./autogen.sh
+}
+
+build() {
+ cd $_pkgname
+ ./configure --prefix=/usr
+ make
+ }
+
+package() {
+ cd $_pkgname
+ DESTDIR="$pkgdir" make install
+ libtool --finish /usr/lib
+}