summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-09-05 13:06:22 +0800
committerzxp198210052023-09-05 13:06:22 +0800
commite61b3929d54a96c9aefb96154ebb08cb0d480fee (patch)
tree0c1904e4e0288d477b764e3b998b659327979c26
downloadaur-e61b3929d54a96c9aefb96154ebb08cb0d480fee.tar.gz
update to 0.0.2
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD26
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..31881ff8be08
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = statusify-bin
+ pkgdesc = Discord rich presence configurator desktop app
+ pkgver = 0.0.2
+ pkgrel = 1
+ url = https://github.com/Orphoros/Statusify
+ arch = x86_64
+ license = GPL3
+ depends = gdk-pixbuf2
+ depends = cairo
+ depends = webkit2gtk
+ depends = glib2
+ depends = gcc-libs
+ depends = glibc
+ depends = libsoup
+ depends = openssl
+ depends = hicolor-icon-theme
+ depends = gtk3
+ provides = statusify=0.0.2
+ conflicts = statusify
+ source = statusify-0.0.2.deb::https://github.com/Orphoros/Statusify/releases/download/v0.0.2/Statusify.linux-x86_64.deb
+ sha256sums = 5d87781e9b1bc1fe447f1924a02c7db850e43b4a91a81aa19368a8804d18b120
+
+pkgname = statusify-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5003347ab014
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=statusify-bin
+_pkgname=Statusify
+pkgver=0.0.2
+pkgrel=1
+pkgdesc="Discord rich presence configurator desktop app"
+arch=('x86_64')
+url="https://github.com/Orphoros/Statusify"
+license=('GPL3')
+provides=("${pkgname%-bin}=${pkgver}")
+conflicts=("${pkgname%-bin}")
+depends=('gdk-pixbuf2' 'cairo' 'webkit2gtk' 'glib2' 'gcc-libs' 'glibc' 'libsoup' 'openssl' 'hicolor-icon-theme' 'gtk3')
+source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/v${pkgver}/${_pkgname}.linux-${CARCH}.deb")
+sha256sums=('5d87781e9b1bc1fe447f1924a02c7db850e43b4a91a81aa19368a8804d18b120')
+prepare() {
+ bsdtar -xf "${srcdir}/data.tar.gz"
+}
+package() {
+ install -Dm755 "${srcdir}/usr/bin/${pkgname%-bin}" -t "${pkgdir}/usr/bin"
+ install -Dm644 "${srcdir}/usr/lib/${pkgname%-bin}/images/"*.svg -t "${pkgdir}/usr/lib/${pkgname%-bin}/images"
+ install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+ for _icons in 32x32 128x128 256x256@2;do
+ install -Dm644 "${srcdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
+ -t "${pkgdir}/usr/share/icons/hicolor/${_icons}/apps"
+ done
+} \ No newline at end of file