summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOlivier Brunel2014-06-10 18:50:40 +0200
committerOlivier Brunel2015-06-08 19:17:49 +0200
commit650268b4f63c102eba83c6606a9f25cb3c895450 (patch)
tree9fd694fed35686b6b8ffaac2bc1bf236fb822d26
downloadaur-650268b4f63c102eba83c6606a9f25cb3c895450.tar.gz
Add statusnotifier
Signed-off-by: Olivier Brunel <jjk@jjacky.com>
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6f16539d63d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = statusnotifier
+ pkgdesc = Library to use KDE's StatusNotifierItem via GObject
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = http://jjacky.com/statusnotifier
+ arch = i686
+ arch = x86_64
+ license = GPL3+
+ depends = glib2
+ depends = gtk3
+ depends = gdk-pixbuf2
+ source = http://jjacky.com/statusnotifier/statusnotifier-0.1.0.tar.gz
+ md5sums = 6ce734ee57886ef0da05098bb8c98f5a
+
+pkgname = statusnotifier
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2605802d2e4b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: jjacky
+pkgname=statusnotifier
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Library to use KDE's StatusNotifierItem via GObject"
+arch=('i686' 'x86_64')
+url="http://jjacky.com/statusnotifier"
+license=('GPL3+')
+depends=('glib2' 'gtk3' 'gdk-pixbuf2')
+source=(http://jjacky.com/$pkgname/$pkgname-$pkgver.tar.gz)
+md5sums=('6ce734ee57886ef0da05098bb8c98f5a')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
+}
+
+# vim:set ts=2 sw=2 et: