summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsuperraiden2022-03-08 21:13:09 +1100
committersuperraiden2022-03-08 21:13:09 +1100
commitb298b99594934171be43e9635b7b9a8d5a54fbd2 (patch)
tree9422d7e230a042bf9193985e06dc042f7ec260e4
downloadaur-b298b99594934171be43e9635b7b9a8d5a54fbd2.tar.gz
Initital commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2d3018df2c65
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = stax2aws-git-bin
+ pkgdesc = stax2aws is a CLI tool that enables you to log in and retrieve temporary credentials granting access to your Stax-managed AWS accounts.
+ pkgver = 1.4.1
+ pkgrel = 1
+ url = https://www.stax.io/developer/aws-access-cli/
+ arch = x86_64
+ license = UNLICENSED
+ optdepends = sudo: privilege elevation
+ optdepends = doas: privilege elevation
+ source = https://github.com/stax-labs/stax2aws-releases/releases/download/v1.4.1/stax2aws_1.4.1_linux_amd64.tar.gz
+ sha256sums = f7700e6bfdab3c1f985710b15ef4212e2448d7fd0105509213f5e9822a4207a2
+
+pkgname = stax2aws-git-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3bf059e0fd6d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+#Maintainer: Thomas R Waller <thomas.r.waller@gmail.com>
+
+_pkgname=stax2aws
+pkgname=$_pkgname-git-bin
+pkgver=1.4.1
+pkgrel=1
+pkgdesc="stax2aws is a CLI tool that enables you to log in and retrieve temporary credentials granting access to your Stax-managed AWS accounts."
+url="https://www.stax.io/developer/aws-access-cli/"
+arch=('x86_64')
+license=('UNLICENSED')
+optdepends=(
+ 'sudo: privilege elevation'
+ 'doas: privilege elevation'
+)
+
+source=("https://github.com/stax-labs/stax2aws-releases/releases/download/v${pkgver}/stax2aws_${pkgver}_linux_amd64.tar.gz")
+sha256sums=('f7700e6bfdab3c1f985710b15ef4212e2448d7fd0105509213f5e9822a4207a2')
+
+package() {
+ mkdir -p "$pkgdir/usr/bin/"
+ install -m755 "stax2aws_${pkgver}_linux_amd64/stax2aws" "$pkgdir/usr/bin/stax2aws"
+}