summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author4shadoww2018-04-05 14:08:01 +0300
committer4shadoww2018-04-05 14:08:01 +0300
commit417aca6d4d0be638d0ee5b5ea40572c9ceda71aa (patch)
treece3b51d3bd5d71c5ed0e33ba3ad1f51afe5fb975
downloadaur-417aca6d4d0be638d0ee5b5ea40572c9ceda71aa.tar.gz
initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD19
3 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fe400d8d0de5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = stb
+ pkgdesc = single-file public domain (or MIT licensed) libraries for C/C++
+ pkgver = 20180211
+ pkgrel = 1
+ url = https://github.com/nothings/stb
+ arch = any
+ license = public domain,
+ license = MIT
+ source = https://github.com/nothings/stb/archive/e6afb9cbae4064da8c3e69af3ff5c4629579c1d2.tar.gz
+ md5sums = e52f1d8c18612d4d7a2eb1c5e2d7ed0f
+
+pkgname = stb
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..186c3af0a47a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Noa-Emil Nissinen <aur dot satella at spamgourmet dot org>
+
+commitsha="e6afb9cbae4064da8c3e69af3ff5c4629579c1d2"
+
+pkgname=stb
+pkgver=20180211
+pkgrel=1
+pkgdesc="single-file public domain (or MIT licensed) libraries for C/C++"
+arch=('any')
+url="https://github.com/nothings/stb"
+license=('public domain', 'MIT')
+source=("https://github.com/nothings/$pkgname/archive/$commitsha.tar.gz")
+md5sums=('e52f1d8c18612d4d7a2eb1c5e2d7ed0f')
+
+package() {
+ cd "$pkgname-$commitsha"
+ mkdir $pkgdir/usr $pkgdir/usr/include $pkgdir/usr/include/stb
+ install *.h $pkgdir/usr/include/stb
+}