summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Knodt2016-07-17 17:59:32 +0200
committerFlorian Knodt2016-07-17 17:59:32 +0200
commit1805290a19238929b4bdefb6488db35569a8c65c (patch)
tree102b10be53289ea1b2f1216e699518197d42ab75
downloadaur-1805290a19238929b4bdefb6488db35569a8c65c.tar.gz
Init, v1.2
-rw-r--r--.SRCINFO18
-rw-r--r--LICENSE20
-rw-r--r--PKGBUILD21
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..459eac6f40c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = stcgal
+ pkgdesc = Open Source STC MCU ISP flash tool
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://github.com/grigorig/stcgal
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python-pyserial
+ depends = python-setuptools
+ optdepends = python-pyusb: Native USB programming support
+ source = https://github.com/grigorig/stcgal/archive/v1.2.zip
+ source = LICENSE
+ md5sums = c942810581b77cf64983c645aa64b797
+ md5sums = 79a3d9f649d76086966bde308915defa
+
+pkgname = stcgal
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..96f2167aedd4
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,20 @@
+Copyright (c) 2013-2015 Grigori Goronzy <greg@chown.ath.cx>
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0c0f96f8417
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Florian Knodt <git [at] adlerweb [dot] info>
+
+pkgname=stcgal
+pkgver=1.2
+pkgrel=1
+pkgdesc="Open Source STC MCU ISP flash tool"
+arch=('any')
+url="https://github.com/grigorig/stcgal"
+license=('MIT')
+depends=('python-pyserial' 'python-setuptools')
+optdepends=('python-pyusb: Native USB programming support')
+makedepends=('git')
+source=("https://github.com/grigorig/stcgal/archive/v1.2.zip" 'LICENSE')
+md5sums=('c942810581b77cf64983c645aa64b797' '79a3d9f649d76086966bde308915defa')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 "${srcdir}"/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+