summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarren Wu2018-09-30 11:48:47 +0800
committerDarren Wu2018-09-30 11:48:47 +0800
commitf251fc30cf756f3bb2118a135af0adb487095d10 (patch)
tree3da1f06c85244b675752271d82bb35975473687b
parentf165ce583568414bcae985ea51c4e893eed482f9 (diff)
downloadaur-f251fc30cf756f3bb2118a135af0adb487095d10.tar.gz
rebuild
-rw-r--r--.SRCINFO12
-rw-r--r--LICENSE20
-rw-r--r--PKGBUILD36
3 files changed, 48 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cfceea0fe310..033cdcbcb72f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
-# Generated by mksrcinfo v8
-# Mon Oct 31 00:38:13 UTC 2016
pkgbase = stcgal-git
pkgdesc = Open Source STC MCU ISP flash tool
- pkgver = r127.86e289b
+ pkgver = v1.6.r1.8e31765
pkgrel = 1
url = https://github.com/grigorig/stcgal
arch = any
license = MIT
makedepends = git
+ makedepends = python-setuptools
depends = python-pyserial
- depends = python-setuptools
+ depends = python-tqdm
optdepends = python-pyusb: Native USB programming support
- conflicts = stcgal
- source = git+https://github.com/grigorig/stcgal
+ source = stcgal::git+https://github.com/grigorig/stcgal.git
+ source = LICENSE
md5sums = SKIP
+ md5sums = b76a68fb137f36d7b43624a0fe99cb2c
pkgname = stcgal-git
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..96f2167aedd4
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,20 @@
+Copyright (c) 2013-2015 Grigori Goronzy <greg@chown.ath.cx>
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
+
diff --git a/PKGBUILD b/PKGBUILD
index 0e875b146070..6a1e0e409bb4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,36 @@
-# Maintainer: Marco Kundt <mrckndt@gmail.com>
+# Maintainer: Darren Wu <$(base64 --decode <<<'ZGFycmVuMTk5NzA4MTBAZ21haWwuY29tCg==')>
+# Thanks: Florian Knodt <git [at] adlerweb [dot] info>
+# Thanks: Marco Kundt <mrckndt@gmail.com>
pkgname=stcgal-git
-pkgver=r127.86e289b
+pkgver=v1.6.r1.8e31765
pkgrel=1
pkgdesc="Open Source STC MCU ISP flash tool"
arch=('any')
-conflicts=('stcgal')
url="https://github.com/grigorig/stcgal"
license=('MIT')
-depends=('python-pyserial' 'python-setuptools')
+depends=('python-pyserial'
+ 'python-tqdm')
optdepends=('python-pyusb: Native USB programming support')
-makedepends=('git')
-source=(git+https://github.com/grigorig/stcgal)
-md5sums=('SKIP')
-
-_gitname='stcgal'
+makedepends=('git'
+ 'python-setuptools')
+source=('stcgal::git+https://github.com/grigorig/stcgal.git'
+ 'LICENSE') # https://aur.archlinux.org/cgit/aur.git/plain/LICENSE?h=stcgal
+md5sums=('SKIP'
+ 'b76a68fb137f36d7b43624a0fe99cb2c')
pkgver() {
- cd "$srcdir/$_gitname"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')" # Git, tags available
}
-package() {
- cd ${srcdir}/${_gitname}
- python setup.py install --root="$pkgdir/" --optimize=1
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ python setup.py build
}
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 "${srcdir}"/LICENSE "${pkgdir}/usr/share/licenses/${pkgname%-git}/LICENSE"
+} \ No newline at end of file