summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcropinghigh2021-08-12 18:28:15 +0300
committercropinghigh2021-08-12 18:28:15 +0300
commit3748edf73e742eed904f8eb3e15600ee4ec4502d (patch)
tree52bddba03226efc323c68a984ea737926624a4cb
downloadaur-3748edf73e742eed904f8eb3e15600ee4ec4502d.tar.gz
initial commit
-rw-r--r--.SRCINFO12
-rwxr-xr-xPKGBUILD25
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e41b47d6eaf1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = stdcdec-git
+ pkgdesc = Stdcdec program to demodulate, decode and parse Inmarsat-C signals
+ pkgver = 1.0
+ pkgrel = 1
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libinmarsatc
+ source = git://github.com/cropinghigh/stdcdec
+ md5sums = SKIP
+
+pkgname = stdcdec-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..3632fd2200e3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Stdcdec program to demodulate, decode and parse Inmarsat-C signals
+# Maintainer: cropinghigh <joinmark60@gmail.com>
+pkgname=stdcdec-git
+pkgver=1.0
+pkgrel=1
+arch=('i686' 'x86_64')
+pkgdesc="Stdcdec program to demodulate, decode and parse Inmarsat-C signals"
+license=('GPL')
+depends=("libinmarsatc")
+provides=("stdcdec")
+source=("git://github.com/cropinghigh/stdcdec")
+md5sums=('SKIP')
+
+build() {
+ cd $srcdir/stdcdec
+ mkdir build
+ cd build
+ cmake ..
+ make
+}
+
+package() {
+ cd $srcdir/stdcdec/build
+ make DESTDIR="$pkgdir/" install
+}