summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcropinghigh2022-03-27 14:55:17 +0300
committercropinghigh2022-03-27 14:55:17 +0300
commitd40a65c0a4481db8a147fce8d642386051b3a377 (patch)
treeda74e58d644970b5523afe900a5d4a0210ef9de7
parent3748edf73e742eed904f8eb3e15600ee4ec4502d (diff)
downloadaur-d40a65c0a4481db8a147fce8d642386051b3a377.tar.gz
update version code + git protocol
-rw-r--r--.SRCINFO5
-rwxr-xr-xPKGBUILD9
2 files changed, 10 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e41b47d6eaf1..9f20aee0da4c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = stdcdec-git
pkgdesc = Stdcdec program to demodulate, decode and parse Inmarsat-C signals
- pkgver = 1.0
+ pkgver = r11.c9a1689
pkgrel = 1
arch = i686
arch = x86_64
license = GPL
depends = libinmarsatc
- source = git://github.com/cropinghigh/stdcdec
+ provides = stdcdec
+ source = git+https://github.com/cropinghigh/stdcdec
md5sums = SKIP
pkgname = stdcdec-git
diff --git a/PKGBUILD b/PKGBUILD
index 3632fd2200e3..2eca4341b933 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,21 @@
# Stdcdec program to demodulate, decode and parse Inmarsat-C signals
# Maintainer: cropinghigh <joinmark60@gmail.com>
pkgname=stdcdec-git
-pkgver=1.0
+pkgver=r11.c9a1689
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="Stdcdec program to demodulate, decode and parse Inmarsat-C signals"
license=('GPL')
depends=("libinmarsatc")
provides=("stdcdec")
-source=("git://github.com/cropinghigh/stdcdec")
+source=("git+https://github.com/cropinghigh/stdcdec")
md5sums=('SKIP')
+pkgver() {
+ cd "$srcdir/stdcdec"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
build() {
cd $srcdir/stdcdec
mkdir build