summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpztrn2015-06-17 20:48:45 +0500
committerpztrn2015-06-17 20:48:45 +0500
commit32834cdf02f88dc01da4bc6e0a093609c887e909 (patch)
tree7ac642b5c9de992fbaa9fc3196e7e2d2f60d319b
downloadaur-32834cdf02f88dc01da4bc6e0a093609c887e909.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3478a47064ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = ste-plugins
+ pkgdesc = STE LADSPA plugins package. Includes stereo panner and width adjuster.
+ pkgver = 0.0.2
+ pkgrel = 1
+ url = http://kokkinizita.linuxaudio.org/linuxaudio/downloads/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = ladspa
+ source = http://kokkinizita.linuxaudio.org/linuxaudio/downloads/STE-plugins-0.0.2.tar.bz2
+ md5sums = 9a6b41cb8594221f7a87cb8662e8699d
+
+pkgname = ste-plugins
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19976f5c900d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Ezra Sharp <nicekiwi@gmail.com>
+
+pkgname=ste-plugins
+_realpkgname=STE-plugins
+pkgver=0.0.2
+pkgrel=1
+pkgdesc='STE LADSPA plugins package. Includes stereo panner and width adjuster.'
+arch=('i686' 'x86_64')
+url='http://kokkinizita.linuxaudio.org/linuxaudio/downloads/'
+license=('GPL2')
+makedepends=('ladspa')
+source=("http://kokkinizita.linuxaudio.org/linuxaudio/downloads/$_realpkgname-$pkgver.tar.bz2")
+md5sums=('9a6b41cb8594221f7a87cb8662e8699d')
+
+build() {
+ cd "$srcdir/$_realpkgname-$pkgver"
+
+ sed -i Makefile -e 's/-O2//' -e 's/g++/$(CXX) $(LDFLAGS)/'
+ make
+}
+
+package() {
+ cd "$srcdir/$_realpkgname-$pkgver"
+ mkdir -p "$pkgdir/usr/lib/ladspa"
+ cp stereo-plugins.so "$pkgdir/usr/lib/ladspa"
+}