summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2017-03-15 08:38:35 +1100
committerMatthew Gamble2017-03-15 08:38:35 +1100
commit40a7bba2434903edeb9814c6e885ecb8df7ee48d (patch)
tree67ae5ee5c72c47edf86cb4924f1ed959a80bd9e4
downloadaur-40a7bba2434903edeb9814c6e885ecb8df7ee48d.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD23
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..533eafa62109
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = steam-fast-login
+ pkgdesc = Login manager for Steam, allowing fast switching between accounts
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://github.com/djmattyg007/SteamFastLogin
+ arch = any
+ license = GPL3
+ depends = python
+ depends = python-setuptools
+ depends = python-appdirs
+ depends = python-pyqt5
+ depends = python-keyring
+ source = https://github.com/djmattyg007/SteamFastLogin/archive/1.0.3.tar.gz
+ sha256sums = 17d89216622a2a9b35f4284e5a88cc15d3851b23db4432ecc832317e4ae46bd0
+
+pkgname = steam-fast-login
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2d72b4cd24ca
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.gz
+*.pkg.tar.xz
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..162bd8035da9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Matthew Gamble <git@matthewgamble.net>
+
+pkgname=steam-fast-login
+pkgver=1.0.3
+pkgrel=1
+pkgdesc="Login manager for Steam, allowing fast switching between accounts"
+arch=("any")
+license=("GPL3")
+url="https://github.com/djmattyg007/SteamFastLogin"
+depends=("python" "python-setuptools" "python-appdirs" "python-pyqt5" "python-keyring")
+source=("https://github.com/djmattyg007/SteamFastLogin/archive/${pkgver}.tar.gz")
+sha256sums=("17d89216622a2a9b35f4284e5a88cc15d3851b23db4432ecc832317e4ae46bd0")
+
+package() {
+ cd "SteamFastLogin-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/steam-fast-login/LICENSE.txt"
+ install -Dm644 steam-fast-login.desktop "${pkgdir}/usr/share/applications/steam-fast-login.desktop"
+ install -Dm644 README.txt "${pkgdir}/usr/share/doc/steam-fast-login/README.txt"
+ for size in 16 32 48 64 128 256; do
+ install -Dm644 steamfastlogin/icons/logo${size}.png "${pkgdir}/usr/share/icons/hicolor/${size}x${size}/apps/steam-fast-login.png"
+ done
+}