summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2023-12-25 21:07:42 -0500
committerPatrick Northon2023-12-25 21:07:42 -0500
commitb3bf3311ca034892b2f0123aa2ffa06b8fe30288 (patch)
tree8733409af885482631738e9e1cf8e3bd66b5e714
parent2eb964b7c2cf5541f91f8f154acf0135c59abcb6 (diff)
downloadaur-b3bf3311ca034892b2f0123aa2ffa06b8fe30288.tar.gz
Small revamp and bump version.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD28
2 files changed, 17 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff23f5dd17b4..041b5bb6556e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
pkgbase = steam-screensaver-fix
pkgdesc = Fix for steam screensaving bug.
- pkgver = r4.97cf918
- pkgrel = 2
+ pkgver = r5.c0f1b3e
+ pkgrel = 1
epoch = 1
url = https://gitlab.com/patlefort/steam-screensaver-fix
arch = i686
arch = x86_64
license = GPL3
makedepends = git
- depends = steam
depends = glibc
- optdepends = steam-native-runtime
- source = git+https://gitlab.com/patlefort/steam-screensaver-fix.git#commit=97cf9181f2a875b440f239bfee6d4e4246f6a017
+ source = git+https://gitlab.com/patlefort/steam-screensaver-fix.git#commit=c0f1b3efe513e21762b263ac1ccf91afb302bb53
sha256sums = SKIP
depends_x86_64 = lib32-glibc
pkgname = steam-screensaver-fix
+ depends = steam
+ depends = sdl2
+ optdepends = steam-native-runtime
diff --git a/PKGBUILD b/PKGBUILD
index b9ccfb358e3c..2c196dfc40f0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,17 @@
# Maintainer: Patrick Northon <northon_patrick3@yahoo.ca>
pkgname=steam-screensaver-fix
-pkgver=r4.97cf918
-pkgrel=2
+pkgver=r5.c0f1b3e
+pkgrel=1
epoch=1
pkgdesc='Fix for steam screensaving bug.'
arch=('i686' 'x86_64')
url='https://gitlab.com/patlefort/steam-screensaver-fix'
license=('GPL3')
-depends=(
- 'steam'
- 'glibc')
-optdepends=(
- 'steam-native-runtime'
-)
-makedepends=(
- 'git'
-)
-depends_x86_64=(
- 'lib32-glibc')
-source=(
- "git+https://gitlab.com/patlefort/steam-screensaver-fix.git#commit=97cf9181f2a875b440f239bfee6d4e4246f6a017")
+depends=('glibc')
+makedepends=('git')
+depends_x86_64=('lib32-glibc')
+source=("git+https://gitlab.com/patlefort/steam-screensaver-fix.git#commit=c0f1b3efe513e21762b263ac1ccf91afb302bb53")
sha256sums=('SKIP')
pkgver() {
@@ -33,14 +24,17 @@ pkgver() {
build() {
# Build 32 bit version.
if [ "$CARCH" = 'x86_64' ]; then
- gcc -m32 -shared -fPIC -ldl -o 'sdl_block_screensaver_inhibit_lib32.so' "$pkgname/sdl_fix_steam_screensaver.c"
+ gcc $CFLAGS $LDFLAGS -m32 -shared -fPIC -ldl -o 'sdl_block_screensaver_inhibit_lib32.so' "$pkgname/sdl_fix_steam_screensaver.c"
fi
# Build native version.
- gcc -shared -fPIC -ldl -o 'sdl_block_screensaver_inhibit.so' "$pkgname/sdl_fix_steam_screensaver.c"
+ gcc $CFLAGS $LDFLAGS -shared -fPIC -ldl -o 'sdl_block_screensaver_inhibit.so' "$pkgname/sdl_fix_steam_screensaver.c"
}
package() {
+ depends=('steam' 'sdl2')
+ optdepends=('steam-native-runtime')
+
[ "$CARCH" = 'x86_64' ] && install -Dm755 'sdl_block_screensaver_inhibit_lib32.so' "${pkgdir}/usr/lib32/sdl_block_screensaver_inhibit.so"
install -Dm755 'sdl_block_screensaver_inhibit.so' -t "${pkgdir}${_prefix}/usr/lib"