summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Northon2021-12-08 03:02:47 -0500
committerPatrick Northon2021-12-08 03:02:47 -0500
commitc01938ca07e8ec01e50d9fae712384b073529ae0 (patch)
tree6027121aa9c6e46237230c1e1d2d5fc3a24a23f7
parent17e2232efe51c79d1b1076a7147566befb6bfcd1 (diff)
downloadaur-c01938ca07e8ec01e50d9fae712384b073529ae0.tar.gz
Update version and revamped to use cmake.
-rw-r--r--.SRCINFO52
-rw-r--r--PKGBUILD108
-rwxr-xr-xsteam-screensaver-fix-native2
3 files changed, 132 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e27af0c6fdeb..33f2a461647f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,39 @@
pkgbase = steam-screensaver-fix
pkgdesc = Fix for steam screensaving bug.
- pkgver = 2.0.16
- pkgrel = 4
+ pkgver = 2.0.18
+ pkgrel = 1
url = https://github.com/ValveSoftware/steam-for-linux/issues/5607
arch = i686
arch = x86_64
license = GPL3
+ makedepends = cmake
+ makedepends = jack
+ makedepends = wayland-protocols
+ makedepends = alsa-lib
+ makedepends = mesa
+ makedepends = libpulse
+ makedepends = libxrandr
+ makedepends = libxinerama
+ makedepends = wayland
+ makedepends = libxkbcommon
+ makedepends = wayland-protocols
+ makedepends = ibus
+ makedepends = fcitx
+ makedepends = libxss
+ makedepends = pipewire
+ makedepends = libdecor
depends = steam
- source = https://www.libsdl.org/release/SDL2-2.0.16.tar.gz
- source = https://www.libsdl.org/release/SDL2-2.0.16.tar.gz.sig
+ depends = glibc
+ depends = libxext
+ depends = libxrender
+ depends = libx11
+ depends = libgl
+ depends = libxcursor
+ depends = libibus
+ depends = hidapi
+ depends = libusb
+ source = https://www.libsdl.org/release/SDL2-2.0.18.tar.gz
+ source = https://www.libsdl.org/release/SDL2-2.0.18.tar.gz.sig
source = steam-screensaver-fix-runtime.desktop
source = steam-screensaver-fix-native.desktop
source = 0001-SDL-allow-screensaver.patch
@@ -16,13 +41,28 @@ pkgbase = steam-screensaver-fix
source = steam-screensaver-fix-runtime
source = steam-screensaver-fix-native
validpgpkeys = 1528635D8053A57F77D1E08630A59377A7763BE6
- sha256sums = 65be9ff6004034b5b2ce9927b5a4db1814930f169c4b2dae0a1e4697075f287b
+ sha256sums = 94d40cd73dbfa10bb6eadfbc28f355992bb2d6ef6761ad9d4074eff95ee5711c
sha256sums = SKIP
sha256sums = 114c7ca82e6b7605c9e88bf569bd7f0d3ddad3f7260ac79c255f7f8f833a5379
sha256sums = 1fdb424e1535aae8ae0acf045cc0b251f14563b7423f895abc6110b1da4c4ef1
sha256sums = a2f2935c0ae252a0e0fe924ebf4083b101689347f782c4a48637e41bdee849ef
sha256sums = fe684fd277bb27cc79c9648d2d44ae9e936717f32b7c099ba05579dd53524840
sha256sums = c14b0f0a7a901d02de53ef7a511b7df7e87d670abb3181872a823d1ce57330f2
- sha256sums = 84573eca1c4006c35ed451d38cad0c7e41e31c819f35ccffffb2dfedfcee10ac
+ sha256sums = bcb88dd0640f53576c949a9f6e2c2c4b7af3665ea080c6e9a89ac9ac398cb220
+ depends_x86_64 = lib32-glibc
+ depends_x86_64 = lib32-libxext
+ depends_x86_64 = lib32-libxrender
+ depends_x86_64 = lib32-libx11
+ depends_x86_64 = lib32-libgl
+ depends_x86_64 = lib32-libxcursor
+ makedepends_x86_64 = lib32-alsa-lib
+ makedepends_x86_64 = lib32-mesa
+ makedepends_x86_64 = lib32-libpulse
+ makedepends_x86_64 = lib32-libxrandr
+ makedepends_x86_64 = lib32-libxinerama
+ makedepends_x86_64 = lib32-wayland
+ makedepends_x86_64 = lib32-libxkbcommon
+ makedepends_x86_64 = lib32-libxss
+ makedepends_x86_64 = lib32-pipewire
pkgname = steam-screensaver-fix
diff --git a/PKGBUILD b/PKGBUILD
index a7db7ae096a6..560a79958f58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,57 @@
# Maintainer: Patrick Northon <northon_patrick3@yahoo.ca>
pkgname=steam-screensaver-fix
-pkgver=2.0.16
-pkgrel=4
+pkgver=2.0.18
+pkgrel=1
pkgdesc='Fix for steam screensaving bug.'
arch=('i686' 'x86_64')
url='https://github.com/ValveSoftware/steam-for-linux/issues/5607'
license=('GPL3')
-depends=('steam')
-makedepends=()
+depends=(
+ 'steam'
+ 'glibc'
+ 'libxext'
+ 'libxrender'
+ 'libx11'
+ 'libgl'
+ 'libxcursor'
+ 'libibus'
+ 'hidapi'
+ 'libusb')
+depends_x86_64=(
+ 'lib32-glibc'
+ 'lib32-libxext'
+ 'lib32-libxrender'
+ 'lib32-libx11'
+ 'lib32-libgl'
+ 'lib32-libxcursor')
+makedepends=(
+ 'cmake'
+ 'jack'
+ 'wayland-protocols'
+ 'alsa-lib'
+ 'mesa'
+ 'libpulse'
+ 'libxrandr'
+ 'libxinerama'
+ 'wayland'
+ 'libxkbcommon'
+ 'wayland-protocols'
+ 'ibus'
+ 'fcitx'
+ 'libxss'
+ 'pipewire'
+ 'libdecor')
+makedepends_x86_64=(
+ 'lib32-alsa-lib'
+ 'lib32-mesa'
+ 'lib32-libpulse'
+ 'lib32-libxrandr'
+ 'lib32-libxinerama'
+ 'lib32-wayland'
+ 'lib32-libxkbcommon'
+ 'lib32-libxss'
+ 'lib32-pipewire')
source=(
"https://www.libsdl.org/release/SDL2-${pkgver}.tar.gz"{,.sig}
'steam-screensaver-fix-runtime.desktop'
@@ -17,42 +60,61 @@ source=(
'steam_sdl_injection.sh'
'steam-screensaver-fix-runtime'
'steam-screensaver-fix-native')
-sha256sums=('65be9ff6004034b5b2ce9927b5a4db1814930f169c4b2dae0a1e4697075f287b'
+sha256sums=('94d40cd73dbfa10bb6eadfbc28f355992bb2d6ef6761ad9d4074eff95ee5711c'
'SKIP'
'114c7ca82e6b7605c9e88bf569bd7f0d3ddad3f7260ac79c255f7f8f833a5379'
'1fdb424e1535aae8ae0acf045cc0b251f14563b7423f895abc6110b1da4c4ef1'
'a2f2935c0ae252a0e0fe924ebf4083b101689347f782c4a48637e41bdee849ef'
'fe684fd277bb27cc79c9648d2d44ae9e936717f32b7c099ba05579dd53524840'
'c14b0f0a7a901d02de53ef7a511b7df7e87d670abb3181872a823d1ce57330f2'
- '84573eca1c4006c35ed451d38cad0c7e41e31c819f35ccffffb2dfedfcee10ac')
+ 'bcb88dd0640f53576c949a9f6e2c2c4b7af3665ea080c6e9a89ac9ac398cb220')
validpgpkeys=('1528635D8053A57F77D1E08630A59377A7763BE6')
+_flags=(
+ -DSDL_STATIC=OFF
+ -DSDL_DLOPEN=ON
+ -DSDL_ARTS=OFF
+ -DSDL_ESD=OFF
+ -DSDL_NAS=OFF
+ -DSDL_ALSA=ON
+ -DSDL_PULSEAUDIO_SHARED=ON
+ -DSDL_VIDEO_WAYLAND=ON
+ -DSDL_RPATH=OFF
+ -DSDL_CLOCK_GETTIME=ON
+ -DSDL_JACK_SHARED=ON
+ -DSDL_PIPEWIRE=ON
+ -DSDL_PIPEWIRE_SHARED=ON
+ -DSDL_XINPUT=ON
+ -DSDL_HIDAPI=ON)
+
prepare() {
- patch -d "SDL2-${pkgver}" -p1 < '0001-SDL-allow-screensaver.patch'
+ cd "SDL2-${pkgver}"
+ patch -p1 -i "${srcdir}/0001-SDL-allow-screensaver.patch"
+ #patch -p1 -i "${srcdir}/fix-hidapi.patch"
+ sed -i '/pkg_search_module.*ibus-1.0/d' 'CMakeLists.txt'
}
build() {
# Build 32 bit version.
- mkdir -p 'lib32'
- pushd 'lib32'
- "../SDL2-${pkgver}/configure" --disable-input-tslib --host=i686-linux-gnu 'CFLAGS=-m32' 'CXXFLAGS=-m32' 'LDFLAGS=-m32'
- make
- popd
+ if [ "$CARCH" = 'x86_64' ]; then
+ (
+ export CC='gcc -m32'
+ export CXX='g++ -m32'
+ export PKG_CONFIG_PATH=/usr/lib32/pkgconfig
+ cmake -S "SDL2-${pkgver}" -B 'lib32' "${_flags[@]}"
+ cmake --build 'lib32'
+ )
+ fi
+
+ # Build native version.
+ cmake -S "SDL2-${pkgver}" -B 'libnative' "${_flags[@]}"
+ cmake --build 'libnative'
- # Build 64 bits version.
- mkdir -p 'lib64'
- pushd 'lib64'
- "../SDL2-${pkgver}/configure" --disable-input-tslib
- make
- popd
}
package() {
- install -Dm755 'lib32/build/.libs/libSDL2-2.0.so.0' "${pkgdir}/usr/lib32/libSDLsteam.so"
- strip "${pkgdir}/usr/lib32/libSDLsteam.so"
-
- install -Dm755 'lib64/build/.libs/libSDL2-2.0.so.0' "${pkgdir}/usr/lib/libSDLsteam.so"
- strip "${pkgdir}/usr/lib/libSDLsteam.so"
+ [ "$CARCH" = 'x86_64' ] && install -Dm755 'lib32/libSDL2-2.0.so' "${pkgdir}/usr/lib32/libSDLsteam.so"
+ install -Dm755 'libnative/libSDL2-2.0.so' "${pkgdir}/usr/lib/libSDLsteam.so"
install -Dm755 'steam_sdl_injection.sh' 'steam-screensaver-fix-runtime' 'steam-screensaver-fix-native' -t "${pkgdir}/usr/bin/"
install -Dm755 'steam-screensaver-fix-runtime.desktop' 'steam-screensaver-fix-native.desktop' -t "${pkgdir}/usr/share/applications/"
diff --git a/steam-screensaver-fix-native b/steam-screensaver-fix-native
index d4a46ff24725..cebfb5c19987 100755
--- a/steam-screensaver-fix-native
+++ b/steam-screensaver-fix-native
@@ -1,3 +1,3 @@
-#!/bin/bash
+#!/usr/bin/env sh
DEBUGGER="steam_sdl_injection.sh" steam-native "$@"