summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFernando Manfredi2016-04-22 00:39:16 -0300
committerFernando Manfredi2016-04-22 00:39:16 -0300
commit30dfe4366c05b1f3f51b7e5489a6973e7608fc14 (patch)
tree8f214bb77e3bc59e7ecf29df6cfbbf1cfc820ccd
downloadaur-30dfe4366c05b1f3f51b7e5489a6973e7608fc14.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD20
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e4883576114
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = steam-tools
+ pkgdesc = Some useful tools for use with steam client and websites.
+ pkgver = 0.6.2
+ pkgrel = 1
+ url = https://github.com/ShyPixie/steam-tools
+ arch = any
+ license = GPL
+ makedepends = python-setuptools
+ depends = python
+ depends = python-beautifulsoup4
+ depends = python-requests
+ depends = python-crypto
+ source = https://github.com/ShyPixie/steam-tools/archive/v0.6.2-beta.tar.gz
+ sha256sums = 9263ff7bb91cdc495772f5b5486cadf482c3723701ba1bb251f94ca8c0b742d2
+
+pkgname = steam-tools
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed39863daa4b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Acidhub <contact@acidhub.click>
+
+pkgname=steam-tools
+pkgver=0.6.2
+pkgrel=1
+pkgdesc="Some useful tools for use with steam client and websites."
+arch=('any')
+url="https://github.com/ShyPixie/steam-tools"
+depends=('python' 'python-beautifulsoup4' 'python-requests' 'python-crypto')
+makedepends=('python-setuptools')
+license=('GPL')
+source=("https://github.com/ShyPixie/$pkgname/archive/v${pkgver}-beta.tar.gz")
+sha256sums=('9263ff7bb91cdc495772f5b5486cadf482c3723701ba1bb251f94ca8c0b742d2')
+
+package() {
+ cd ${pkgname}-${pkgver}-beta
+ python setup.py install --root=$pkgdir --prefix=/usr
+}
+
+