summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFernando Manfredi2018-10-27 00:28:12 -0300
committerFernando Manfredi2018-10-27 00:28:12 -0300
commit0ba9b2b2f13dee04ab3ccc64af44e36ae32adaa1 (patch)
treedf67be7337cb9e0dc0c0bd8cd47e193918e710cc
parent8bb0bbd4aaaffe37085d91c55d99b1801d780410 (diff)
downloadaur-0ba9b2b2f13dee04ab3ccc64af44e36ae32adaa1.tar.gz
bump to v0.7
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
-rw-r--r--fix_noi18n.patch15
3 files changed, 12 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2682d3eb3fc5..7d0b88e69f89 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = steam-tools-ng
pkgdesc = Some useful tools for use with Steam client and some steam related websites.
- pkgver = 0.3.1
+ pkgver = 0.7
pkgrel = 1
url = https://github.com/ShyPixie/steam-tools-ng
arch = any
license = GPL
makedepends = python-setuptools
makedepends = python-certifi
- depends = python>=3.6
+ depends = python>=3.7
depends = python-aiohttp
depends = python-gobject
depends = stlib
- source = https://github.com/ShyPixie/steam-tools-ng/releases/download/v0.3.1/steam-tools-ng-0.3.1.linux.tar.gz
- source = fix_noi18n.patch
- sha256sums = 1facaa97909f8271d88deb06f0c67a873597bcc40e3306ef88a4cc5cb4874dd3
- sha256sums = c03494d29a1feaceb3ebc06c3e9112f96a7e92f6d84d729a7b9b349d9e9e165b
+ depends = stlib-plugins-git
+ source = https://github.com/ShyPixie/steam-tools-ng/archive/v0.7.tar.gz
+ sha256sums = d8a99552c1f3b2900359313c737b230bb4a5af5b4478a13ae28a18e217b2b71a
pkgname = steam-tools-ng
diff --git a/PKGBUILD b/PKGBUILD
index a715370a1c1b..d1c2cccb5bd4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,26 @@
# Maintainer: Acidhub <dev@acidhub.click>
pkgname=steam-tools-ng
-pkgver=0.3.1
+pkgver=0.7
pkgrel=1
pkgdesc="Some useful tools for use with Steam client and some steam related websites."
arch=('any')
url="https://github.com/ShyPixie/steam-tools-ng"
-depends=('python>=3.6' 'python-aiohttp' 'python-gobject' 'stlib')
+depends=('python>=3.7' 'python-aiohttp' 'python-gobject' 'stlib' 'stlib-plugins-git')
makedepends=('python-setuptools' 'python-certifi')
license=('GPL')
-source=("https://github.com/ShyPixie/$pkgname/releases/download/v${pkgver}/$pkgname-$pkgver.linux.tar.gz"
- 'fix_noi18n.patch')
-sha256sums=('1facaa97909f8271d88deb06f0c67a873597bcc40e3306ef88a4cc5cb4874dd3'
- 'c03494d29a1feaceb3ebc06c3e9112f96a7e92f6d84d729a7b9b349d9e9e165b')
-
-prepare() {
- cd ${pkgname}-${pkgver}.dev1
- patch -uN setup.py ../fix_noi18n.patch || return 1
-}
+source=("https://github.com/ShyPixie/$pkgname/archive/v${pkgver}.tar.gz")
+sha256sums=('d8a99552c1f3b2900359313c737b230bb4a5af5b4478a13ae28a18e217b2b71a')
build() {
- cd ${pkgname}-${pkgver}.dev1
+ cd $pkgname-$pkgver
python setup.py build
}
package() {
- cd ${pkgname}-${pkgver}.dev1
+ cd $pkgname-$pkgver
python setup.py install --skip-build --optimize=1 --root=$pkgdir
+ install -Dm644 steam-tools-ng.desktop $pkgdir/usr/share/applications/steam-tools-ng.desktop
}
diff --git a/fix_noi18n.patch b/fix_noi18n.patch
deleted file mode 100644
index 48837d17b8c5..000000000000
--- a/fix_noi18n.patch
+++ /dev/null
@@ -1,15 +0,0 @@
---- setup.py.orig 2018-06-28 19:01:01.480588486 -0300
-+++ setup.py 2018-06-28 19:02:26.820586709 -0300
-@@ -240,10 +240,10 @@
- scripts=['steam-tools-ng.py'],
- requires=['stlib', 'aiohttp'],
- cmdclass={
-- 'build_py': BuildTranslations,
-+# 'build_py': BuildTranslations,
- 'install': Install,
- 'install_scripts': RemoveExtension,
-- 'install_data': InstallTranslations,
-+# 'install_data': InstallTranslations,
- },
- **freeze_options(),
- **data_files()