summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShyPixie2023-07-21 15:53:52 -0300
committerShyPixie2023-07-21 15:53:52 -0300
commit468e6da9446acea6c5cd2bf648e0b5044840ea16 (patch)
treec7ec01936fbf4381e26aad4c7f34a751675f10c9
parent0f26ef7d0eb9fbcf158305c99c55a499040fc6d6 (diff)
downloadaur-468e6da9446acea6c5cd2bf648e0b5044840ea16.tar.gz
Update to v3.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce13f6f37a75..9874d3a596e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = steam-tools-ng
pkgdesc = Some useful tools for use with steam client or compatible programs, websites
- pkgver = 3.0.1
- pkgrel = 2
+ pkgver = 3.1
+ pkgrel = 1
url = https://github.com/calendulish/steam-tools-ng
arch = any
license = GPL
@@ -12,13 +12,11 @@ pkgbase = steam-tools-ng
depends = python>=3.9
depends = python-certifi
depends = python-aiohttp
- depends = python-stlib>=1.3
- depends = python-stlib-plugins>=1.2
+ depends = python-stlib>=2.0
+ depends = python-stlib-plugins>=1.2.3
depends = python-gobject
depends = gtk4
- source = https://github.com/calendulish/steam-tools-ng/archive/v3.0.1.tar.gz
- source = steam-tools-ng-3.0.1-pygobject-fix.patch
- sha256sums = c0fa03ec0e9d29aa35efce30fee65fa49e9dd6ae0bda2d289dd96171afca5b01
- sha256sums = 4817bc7b0e816fa3789f9c960b3351affd73148b839fffaa63ca0537558100f3
+ source = https://github.com/calendulish/steam-tools-ng/archive/v3.1.tar.gz
+ sha256sums = 00a1e88cb8e6733c7704875b593c9948008f5792556b70fda58a1daf9e72584d
pkgname = steam-tools-ng
diff --git a/PKGBUILD b/PKGBUILD
index b81c2135630b..442ce1434a21 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,18 @@
# Contributor: Acidhub <dev@acidhub.click>
pkgname=steam-tools-ng
-pkgver=3.0.1
-pkgrel=2
+pkgver=3.1
+pkgrel=1
pkgdesc="Some useful tools for use with steam client or compatible programs, websites"
arch=('any')
url="https://github.com/calendulish/steam-tools-ng"
-depends=('python>=3.9' 'python-certifi' 'python-aiohttp' 'python-stlib>=1.3' 'python-stlib-plugins>=1.2' 'python-gobject' 'gtk4')
+depends=('python>=3.9' 'python-certifi' 'python-aiohttp' 'python-stlib>=2.0' 'python-stlib-plugins>=1.2.3' 'python-gobject' 'gtk4')
makedepends=('python-build' 'python-installer' 'python-wheel' 'imagemagick')
license=('GPL')
source=(
"https://github.com/calendulish/$pkgname/archive/v${pkgver}.tar.gz"
- "steam-tools-ng-3.0.1-pygobject-fix.patch"
)
-sha256sums=('c0fa03ec0e9d29aa35efce30fee65fa49e9dd6ae0bda2d289dd96171afca5b01'
- '4817bc7b0e816fa3789f9c960b3351affd73148b839fffaa63ca0537558100f3')
-
-prepare() {
- cd $pkgname-$pkgver
- patch -Np1 < "../steam-tools-ng-3.0.1-pygobject-fix.patch"
-}
+sha256sums=('00a1e88cb8e6733c7704875b593c9948008f5792556b70fda58a1daf9e72584d')
build() {
cd $pkgname-$pkgver