summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShyPixie2023-01-13 11:43:13 -0300
committerShyPixie2023-01-13 11:43:13 -0300
commit507231e4e8045beb510c0265309a22f1b51556c3 (patch)
tree39c5078678b107e0e54fbe20d7760a5e5bd886b5
parent270669f8c65313ef7371161bf11785e753d43449 (diff)
downloadaur-507231e4e8045beb510c0265309a22f1b51556c3.tar.gz
Update to v2.1.0
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD24
2 files changed, 23 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5cbbb8b88696..4622440a64d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,22 @@
pkgbase = steam-tools-ng
- pkgdesc = Some useful tools for use with Steam client and some steam related websites.
- pkgver = 1.0.3
+ pkgdesc = Some useful tools for use with steam client or compatible programs, websites
+ pkgver = 2.1.0
pkgrel = 1
url = https://github.com/ShyPixie/steam-tools-ng
arch = any
license = GPL
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
makedepends = imagemagick
- depends = python>=3.7
+ depends = python>=3.9
depends = python-certifi
depends = python-aiohttp
+ depends = python-stlib>=1.1
+ depends = python-stlib-plugins>=1.1
depends = python-gobject
- depends = stlib>=0.12.1
- depends = stlib-plugins-git
- source = https://github.com/ShyPixie/steam-tools-ng/archive/v1.0.3.tar.gz
- sha256sums = 663c0a0a013856b21a1f45d7141280591d0990c9573ac6d1afbd497ea42364a5
+ depends = gtk4
+ source = https://github.com/ShyPixie/steam-tools-ng/archive/v2.1.0.tar.gz
+ sha256sums = 6348ccdf49d631e6d8a1e1f08809e40cf78f4eae519c1bdfe76d82a04f6a2a47
pkgname = steam-tools-ng
diff --git a/PKGBUILD b/PKGBUILD
index 10923496d9fc..47f2ea1620e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,31 @@
-# Maintainer: Felix Golatofski <contact@xdfr.de>
+# Maintainer: Lara <dev@lara.monster
+# Contributor: Felix Golatofski <contact@xdfr.de>
# Contributor: Acidhub <dev@acidhub.click>
pkgname=steam-tools-ng
-pkgver=1.0.3
+pkgver=2.1.0
pkgrel=1
-pkgdesc="Some useful tools for use with Steam client and some steam related websites."
+pkgdesc="Some useful tools for use with steam client or compatible programs, websites"
arch=('any')
url="https://github.com/ShyPixie/steam-tools-ng"
-depends=('python>=3.7' 'python-certifi' 'python-aiohttp' 'python-gobject' 'stlib>=0.12.1' 'stlib-plugins-git')
-makedepends=('python-setuptools' 'imagemagick')
+depends=('python>=3.9' 'python-certifi' 'python-aiohttp' 'python-stlib>=1.1' 'python-stlib-plugins>=1.1' 'python-gobject' 'gtk4')
+makedepends=('python-build' 'python-installer' 'python-wheel' 'imagemagick')
license=('GPL')
source=("https://github.com/ShyPixie/$pkgname/archive/v${pkgver}.tar.gz")
-sha256sums=('663c0a0a013856b21a1f45d7141280591d0990c9573ac6d1afbd497ea42364a5')
+sha256sums=('6348ccdf49d631e6d8a1e1f08809e40cf78f4eae519c1bdfe76d82a04f6a2a47')
build() {
cd $pkgname-$pkgver
- python setup.py build
+ python -m build --wheel --no-isolation
}
package() {
cd $pkgname-$pkgver
- python setup.py install --skip-build --optimize=1 --root=$pkgdir
- sed -i "s|^Icon=.*|Icon=stng|g" steam-tools-ng.desktop
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ sed -i "s|^Icon=.*|Icon=steam-tools-ng|g" steam-tools-ng.desktop
install -Dm644 steam-tools-ng.desktop $pkgdir/usr/share/applications/steam-tools-ng.desktop
- cd build/lib/steam_tools_ng/icons/
- convert -resize 512x512 stng.png stng.png
- install -Dm644 stng.png -t $pkgdir/usr/share/icons/hicolor/512x512/apps
+ convert -resize 512x512 src/steam_tools_ng/icons/stng.png steam-tools-ng.png
+ install -Dm644 steam-tools-ng.png -t "$pkgdir"/usr/share/icons/hicolor/512x512/apps
}