summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFernando Manfredi2018-06-28 19:24:06 -0300
committerFernando Manfredi2018-06-29 11:58:41 -0300
commit8bb0bbd4aaaffe37085d91c55d99b1801d780410 (patch)
tree60c0d120285182ae3179f4933ba11b2ccbf35bca
downloadaur-8bb0bbd4aaaffe37085d91c55d99b1801d780410.tar.gz
Initial package
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
-rw-r--r--fix_noi18n.patch15
3 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2682d3eb3fc5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = steam-tools-ng
+ pkgdesc = Some useful tools for use with Steam client and some steam related websites.
+ pkgver = 0.3.1
+ pkgrel = 1
+ url = https://github.com/ShyPixie/steam-tools-ng
+ arch = any
+ license = GPL
+ makedepends = python-setuptools
+ makedepends = python-certifi
+ depends = python>=3.6
+ depends = python-aiohttp
+ depends = python-gobject
+ depends = stlib
+ source = https://github.com/ShyPixie/steam-tools-ng/releases/download/v0.3.1/steam-tools-ng-0.3.1.linux.tar.gz
+ source = fix_noi18n.patch
+ sha256sums = 1facaa97909f8271d88deb06f0c67a873597bcc40e3306ef88a4cc5cb4874dd3
+ sha256sums = c03494d29a1feaceb3ebc06c3e9112f96a7e92f6d84d729a7b9b349d9e9e165b
+
+pkgname = steam-tools-ng
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a715370a1c1b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Acidhub <dev@acidhub.click>
+
+pkgname=steam-tools-ng
+pkgver=0.3.1
+pkgrel=1
+pkgdesc="Some useful tools for use with Steam client and some steam related websites."
+arch=('any')
+url="https://github.com/ShyPixie/steam-tools-ng"
+depends=('python>=3.6' 'python-aiohttp' 'python-gobject' 'stlib')
+makedepends=('python-setuptools' 'python-certifi')
+license=('GPL')
+source=("https://github.com/ShyPixie/$pkgname/releases/download/v${pkgver}/$pkgname-$pkgver.linux.tar.gz"
+ 'fix_noi18n.patch')
+sha256sums=('1facaa97909f8271d88deb06f0c67a873597bcc40e3306ef88a4cc5cb4874dd3'
+ 'c03494d29a1feaceb3ebc06c3e9112f96a7e92f6d84d729a7b9b349d9e9e165b')
+
+prepare() {
+ cd ${pkgname}-${pkgver}.dev1
+ patch -uN setup.py ../fix_noi18n.patch || return 1
+}
+
+build() {
+ cd ${pkgname}-${pkgver}.dev1
+ python setup.py build
+}
+
+package() {
+ cd ${pkgname}-${pkgver}.dev1
+ python setup.py install --skip-build --optimize=1 --root=$pkgdir
+}
+
+
diff --git a/fix_noi18n.patch b/fix_noi18n.patch
new file mode 100644
index 000000000000..48837d17b8c5
--- /dev/null
+++ b/fix_noi18n.patch
@@ -0,0 +1,15 @@
+--- setup.py.orig 2018-06-28 19:01:01.480588486 -0300
++++ setup.py 2018-06-28 19:02:26.820586709 -0300
+@@ -240,10 +240,10 @@
+ scripts=['steam-tools-ng.py'],
+ requires=['stlib', 'aiohttp'],
+ cmdclass={
+- 'build_py': BuildTranslations,
++# 'build_py': BuildTranslations,
+ 'install': Install,
+ 'install_scripts': RemoveExtension,
+- 'install_data': InstallTranslations,
++# 'install_data': InstallTranslations,
+ },
+ **freeze_options(),
+ **data_files()