summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorShyPixie2023-04-27 20:38:41 -0300
committerShyPixie2023-08-05 06:51:28 -0300
commit9ebad45941c7a58959df2e62ad26f1972ace8754 (patch)
tree23699fa60fafd809abaac5b057739abbce3e6363
parenta39f509a0e38f57d66b8fd8d012ed0b36aef0c64 (diff)
downloadaur-9ebad45941c7a58959df2e62ad26f1972ace8754.tar.gz
Readd pygobject fix to steam-tools-ng
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
-rw-r--r--steam-tools-ng-3.0.1-pygobject-fix.patch49
3 files changed, 12 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4dc0a40b22f..f16b86528da6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = steam-tools-ng
pkgdesc = Some useful tools for use with steam client or compatible programs, websites
pkgver = 3.1.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/calendulish/steam-tools-ng
arch = any
license = GPL
@@ -17,6 +17,8 @@ pkgbase = steam-tools-ng
depends = python-gobject
depends = gtk4
source = https://github.com/calendulish/steam-tools-ng/archive/v3.1.1.tar.gz
+ source = https://github.com/calendulish/steam-tools-ng/commit/b49deac04211c6c010a6db0f3b9cc06a646fd0c1.patch
sha256sums = 4af918fd74c020451eef29375781c6bb2cb7a05afba4e64f05a886b3fe84ca89
+ sha256sums = 6433d67ca6a0a4555cbff98314ff5c196f32ca8dcf6519cf86a093269da322cc
pkgname = steam-tools-ng
diff --git a/PKGBUILD b/PKGBUILD
index 5473c968c530..36e814177791 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=steam-tools-ng
pkgver=3.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="Some useful tools for use with steam client or compatible programs, websites"
arch=('any')
url="https://github.com/calendulish/steam-tools-ng"
@@ -13,8 +13,15 @@ makedepends=('python-build' 'python-installer' 'python-wheel' 'imagemagick')
license=('GPL')
source=(
"https://github.com/calendulish/$pkgname/archive/v${pkgver}.tar.gz"
+ "https://github.com/calendulish/$pkgname/commit/b49deac04211c6c010a6db0f3b9cc06a646fd0c1.patch"
)
-sha256sums=('4af918fd74c020451eef29375781c6bb2cb7a05afba4e64f05a886b3fe84ca89')
+sha256sums=('4af918fd74c020451eef29375781c6bb2cb7a05afba4e64f05a886b3fe84ca89'
+ '6433d67ca6a0a4555cbff98314ff5c196f32ca8dcf6519cf86a093269da322cc')
+
+prepare() {
+ cd $pkgname-$pkgver
+ patch -Np1 < "../b49deac04211c6c010a6db0f3b9cc06a646fd0c1.patch"
+}
build() {
cd $pkgname-$pkgver
diff --git a/steam-tools-ng-3.0.1-pygobject-fix.patch b/steam-tools-ng-3.0.1-pygobject-fix.patch
deleted file mode 100644
index d47bcb68ddbd..000000000000
--- a/steam-tools-ng-3.0.1-pygobject-fix.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-diff --git a/src/steam_tools_ng/gtk/utils.py b/src/steam_tools_ng/gtk/utils.py
-index d9e2873..54d8cc4 100644
---- a/src/steam_tools_ng/gtk/utils.py
-+++ b/src/steam_tools_ng/gtk/utils.py
-@@ -273,7 +273,13 @@ class SimpleStatus(Gtk.Frame):
- super().__init__()
- self._style_context = self.get_style_context()
- self._style_provider = Gtk.CssProvider()
-- self._style_provider.load_from_data(b"frame { background-color: black; }")
-+
-+ # TODO: Temporary fix for pygobject (#27)
-+ if (Gtk.get_major_version(), Gtk.get_minor_version()) >= (4, 9):
-+ self._style_provider.load_from_data("frame { background-color: black; }", -1)
-+ else:
-+ self._style_provider.load_from_data(b"frame { background-color: black; }")
-+
- self._style_context.add_provider(self._style_provider, Gtk.STYLE_PROVIDER_PRIORITY_APPLICATION)
-
- self._grid = Gtk.Grid()
-diff --git a/src/steam_tools_ng/gtk/window.py b/src/steam_tools_ng/gtk/window.py
-index 0c3ed4a..d475aa1 100644
---- a/src/steam_tools_ng/gtk/window.py
-+++ b/src/steam_tools_ng/gtk/window.py
-@@ -46,11 +46,20 @@ class Main(Gtk.ApplicationWindow):
- _display = Gdk.Display.get_default()
- _style_provider = Gtk.CssProvider()
-
-- _style_provider.load_from_data(
-- b"* { border-radius: 2px; }"
-- b"label.warning { background-color: darkblue; color: white; }"
-- b"label.critical { background-color: darkred; color: white; }"
-- )
-+ # TODO: Temporary fix for pygobject (#27)
-+ if (Gtk.get_major_version(), Gtk.get_minor_version()) >= (4, 9):
-+ _style_provider.load_from_data(
-+ "* { border-radius: 2px; }"
-+ "label.warning { background-color: darkblue; color: white; }"
-+ "label.critical { background-color: darkred; color: white; }",
-+ -1
-+ )
-+ else:
-+ _style_provider.load_from_data(
-+ b"* { border-radius: 2px; }"
-+ b"label.warning { background-color: darkblue; color: white; }"
-+ b"label.critical { background-color: darkred; color: white; }"
-+ )
-
- _style_context = self.get_style_context()
-