summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpyamsoft2015-09-12 10:23:09 -0700
committerpyamsoft2015-09-12 10:23:09 -0700
commit42489f2fc7a6a87c1ee889a6e6165beba17d3975 (patch)
tree220d1f0dba51dce7f74f1a3837053c13df53e8bb
parent88ff35d35d85db11c8489483910b4987c81e6441 (diff)
downloadaur-42489f2fc7a6a87c1ee889a6e6165beba17d3975.tar.gz
Updated PKGBUILD to better adhere to packaging guidelines
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD23
2 files changed, 13 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0fb7ef398f69..eeacf547950f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = steam-wrapper-git
pkgdesc = Steam wrapper for common operations (git version)
- pkgver = 0.1.8.git
- pkgrel = 2
+ pkgver = 0.1.8.r59.758146d
+ pkgrel = 1
url = https://github.com/pyamsoft/steam-wrapper.git
arch = i686
arch = x86_64
- license = custom
+ license = GPLv2
makedepends = git
depends = steam
depends = bash
depends = coreutils
+ depends = findutils
optdepends = steam-native: Native runtime library support
optdepends = steam-libs: Native steam libraries support
provides = steam-wrapper
diff --git a/PKGBUILD b/PKGBUILD
index ff5ec6fb1702..85f032714670 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,40 +3,35 @@
pkgname=steam-wrapper-git
_gitname=steam-wrapper
pkgdesc="Steam wrapper for common operations (git version)"
-pkgver=0.1.8.git
-pkgrel=2
+pkgver=0.1.8.r59.758146d
+pkgrel=1
arch=('i686' 'x86_64')
optdepends=('steam-native: Native runtime library support' 'steam-libs: Native steam libraries support')
-depends=('steam' 'bash' 'coreutils')
+depends=('steam' 'bash' 'coreutils' 'findutils')
makedepends=('git')
provides=('steam-wrapper')
conflicts=('steam-wrapper')
-license=('custom')
+license=('GPLv2')
url="https://github.com/pyamsoft/steam-wrapper.git"
source=("${_gitname}::git+${url}#branch=dev")
sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$_gitname"
- echo "$(awk -F '=' '{if (/^VERSION=/) {print $2}}' 'steam-wrapper').git"
+ printf "%s.r%s.%s" "$(awk -F '=' '{if (/^VERSION=/) {print $2}}' 'steam-wrapper')" \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
cd "$srcdir/$_gitname"
# Install the script
- mkdir -p "$pkgdir"/usr/bin/
- cp "${_gitname}" "$pkgdir"/usr/bin/
- chmod 755 "$pkgdir"/usr/bin/${_gitname}
+ install -Dm 755 "${_gitname}" "${pkgdir}/usr/bin/${_gitname}"
# Install the desktop file
- mkdir -p "$pkgdir"/usr/share/applications/
- cp ${_gitname}.desktop "$pkgdir"/usr/share/applications/
- chmod 644 "$pkgdir"/usr/share/applications/${_gitname}.desktop
+ install -Dm644 "${_gitname}.desktop" "${pkgdir}/usr/share/applications/${_gitname}.desktop"
# Install the default configuration
- mkdir -p "$pkgdir"/etc/steam-wrapper/
- cp ${_gitname}.conf "$pkgdir"/etc/${_gitname}/${_gitname}.conf
- chmod 644 "$pkgdir"/etc/${_gitname}/${_gitname}.conf
+ install -Dm 644 "${_gitname}.conf" "${pkgdir}/etc/${_gitname}/${_gitname}.conf"
}