summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpyamsoft2015-06-08 20:40:15 -0700
committerpyamsoft2015-06-08 20:40:15 -0700
commit73e4c60382a79b2f98af0f21c80381504844851e (patch)
treeae86f579429ccf188a21a785db4642c79a76e849
downloadaur-73e4c60382a79b2f98af0f21c80381504844851e.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD35
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..16b7401dd21c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = steam-wrapper-git
+ pkgdesc = Steam wrapper for common operations (git version)
+ pkgver = 0.1.6
+ pkgrel = 1
+ url = https://github.com/pyamsoft/steam-wrapper.git
+ arch = i686
+ arch = x86_64
+ license = custom
+ depends = steam
+ depends = bash
+ depends = coreutils
+ depends = git
+ optdepends = steam-native: Native runtime library support
+ provides = steam-wrapper
+ conflicts = steam-wrapper
+ source = steam-wrapper::git+https://github.com/pyamsoft/steam-wrapper.git#branch=dev
+ sha256sums = SKIP
+
+pkgname = steam-wrapper-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fbe848336d1a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+## Maintainer: pyamsoft <pyam.soft@gmail.com>
+
+pkgname=steam-wrapper-git
+_gitname=steam-wrapper
+pkgdesc="Steam wrapper for common operations (git version)"
+pkgver=0.1.6
+pkgrel=1
+arch=('i686' 'x86_64')
+optdepends=('steam-native: Native runtime library support')
+depends=('steam' 'bash' 'coreutils' 'git')
+provides=('steam-wrapper')
+conflicts=('steam-wrapper')
+license=('custom')
+url="https://github.com/pyamsoft/steam-wrapper.git"
+source=("${_gitname}::git+${url}#branch=dev")
+sha256sums=('SKIP')
+
+package() {
+ cd "$srcdir/$_gitname"
+
+ # Install the script
+ mkdir -p "$pkgdir"/usr/bin/
+ cp "${_gitname}" "$pkgdir"/usr/bin/
+ chmod 755 "$pkgdir"/usr/bin/${_gitname}
+
+ # Install the desktop file
+ mkdir -p "$pkgdir"/usr/share/applications/
+ cp ${_gitname}.desktop "$pkgdir"/usr/share/applications/
+ chmod 644 "$pkgdir"/usr/share/applications/${_gitname}.desktop
+
+ # Install the default configuration
+ mkdir -p "$pkgdir"/etc/steam-wrapper/
+ cp ${_gitname}.conf "$pkgdir"/etc/${_gitname}/${_gitname}.conf
+ chmod 644 "$pkgdir"/etc/${_gitname}/${_gitname}.conf
+}