summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpyamsoft2015-12-03 21:45:14 -0800
committerpyamsoft2015-12-03 21:45:14 -0800
commit74b32d76387f4135f356bda7c90e4dca4f41f2d5 (patch)
treea15836a2f4df4a3f44677be7290a0bbf1a1357f5
parentf31aa8a65258945d78d837d264e841d0ffd8f25a (diff)
downloadaur-74b32d76387f4135f356bda7c90e4dca4f41f2d5.tar.gz
Update to 2.0.
Adds support for overriding the USE_RUNTIME and CLOSE_TO_TRAY by specifying command line arguments The first argument controls the use of the runtime. 1 is USE_RUNTIME 0 is NO_RUNTIME The second argument controls the close to tray flag 1 is CLOSE_TO_TRAY 0 is NO_CLOSE_TO_TRAY Cleans up logging methods and variable definitions
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD33
2 files changed, 17 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d644866adff..3a354a52dcc6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = steam-wrapper-git
pkgdesc = Steam wrapper for common operations (git version)
- pkgver = 0.1.9.r64.817d01c
+ pkgver = 0.2.0.r76.13ea9ee
pkgrel = 1
url = https://github.com/pyamsoft/steam-wrapper.git
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 2682c04548ff..d85465da80b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=steam-wrapper-git
_gitname=steam-wrapper
pkgdesc="Steam wrapper for common operations (git version)"
-pkgver=0.1.9.r64.817d01c
+pkgver=0.2.0.r76.13ea9ee
pkgrel=1
arch=('i686' 'x86_64')
optdepends=('steam-native: Native runtime library support' \
@@ -18,26 +18,25 @@ source=("${_gitname}::git+${url}#branch=dev")
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/$_gitname"
- printf "%s.r%s.%s" "$(awk -F '=' \
- '{if (/^wrapper_version=/) {print $2}}' \
- 'steam-wrapper')" \
- "$(git rev-list --count HEAD)" \
- "$(git rev-parse --short HEAD)"
+ cd "$srcdir/$_gitname"
+ printf "%s.r%s.%s" "$(awk -F '=' \
+ '{if (/^wrapper_version=/) {print $2}}' \
+ 'steam-wrapper')" \
+ "$(git rev-list --count HEAD)" \
+ "$(git rev-parse --short HEAD)"
}
package() {
- cd "$srcdir/$_gitname"
+ cd "$srcdir/$_gitname"
- # Install the script
- install -Dm 755 "${_gitname}" "${pkgdir}/usr/bin/${_gitname}"
+ # Install the script
+ install -Dm 755 "${_gitname}" "${pkgdir}/usr/bin/${_gitname}"
+ # Install the desktop file
+ install -Dm644 "${_gitname}.desktop" \
+ "${pkgdir}/usr/share/applications/${_gitname}.desktop"
- # Install the desktop file
- install -Dm644 "${_gitname}.desktop" \
- "${pkgdir}/usr/share/applications/${_gitname}.desktop"
-
- # Install the default configuration
- install -Dm 644 "${_gitname}.conf" \
- "${pkgdir}/etc/${_gitname}/${_gitname}.conf"
+ # Install the default configuration
+ install -Dm 644 "${_gitname}.conf" \
+ "${pkgdir}/etc/${_gitname}/${_gitname}.conf"
}