summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaylor Smock2015-08-09 18:59:54 -0600
committerTaylor Smock2015-08-09 18:59:54 -0600
commit7d4c5a8ed0b27ac3defeee5bfe2feeb972bf3287 (patch)
treeb8f402e9f460cf0735ae7ef39ab337d087f910d1
parent0033f87cb8696c5705e479947c6c193899b9ada7 (diff)
downloadaur-7d4c5a8ed0b27ac3defeee5bfe2feeb972bf3287.tar.gz
Updated git version number
* Moved steam from optdepends to depends * Added install file to say that steamcurses really needs Steam
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
-rw-r--r--steamcurses-git.install21
3 files changed, 30 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index acfb04097ee0..8f27b17efeaf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = steamcurses-git
pkgdesc = Steam Ncurses for both native and wine versions
- pkgver = 8c106e6
- pkgrel = 2
+ pkgver = 71c0a6d3
+ pkgrel = 1
url = https://github.com/TOTBWF/SteamCurses
+ install = steamcurses-git.install
changelog = changelog.txt
arch = i686
arch = x86_64
license = MIT
depends = ncurses
- optdepends = steam: Native Steam support
+ depends = steam
optdepends = wine: Wine Steam support
provides = steamcurses
conflicts = steamcurses
diff --git a/PKGBUILD b/PKGBUILD
index a2d22cadbff6..d5fc65be0435 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,18 @@
pkgname=steamcurses-git
_pkgname=${pkgname%-git}
_srcname=SteamCurses
-pkgver=8c106e6
-pkgrel=2
+pkgver=71c0a6d
+pkgrel=1
pkgdesc="Steam Ncurses for both native and wine versions"
arch=('i686' 'x86_64')
url="https://github.com/TOTBWF/SteamCurses"
license=('MIT')
-depends=('ncurses')
-optdepends=('steam: Native Steam support'
- 'wine: Wine Steam support')
+depends=('ncurses' 'steam')
+optdepends=('wine: Wine Steam support')
provides=('steamcurses')
conflicts=('steamcurses')
changelog=changelog.txt
+install=${pkgname}.install
source=('git+https://github.com/TOTBWF/SteamCurses.git')
sha256sums=('SKIP')
diff --git a/steamcurses-git.install b/steamcurses-git.install
new file mode 100644
index 000000000000..20cafd201075
--- /dev/null
+++ b/steamcurses-git.install
@@ -0,0 +1,21 @@
+# Colored makepkg-like functions
+msg_blue() {
+ printf "${blue}==>${bold} $1${all_off}\n"
+}
+
+note() {
+ printf "${blue}==>${yellow} NOTE:${bold} $1${all_off}\n"
+}
+
+all_off="$(tput sgr0)"
+bold="${all_off}$(tput bold)"
+blue="${bold}$(tput setaf 4)"
+yellow="${bold}$(tput setaf 3)"
+
+post_install() {
+ note "Steam is needed for core functionality -- native and non-native steam is needed for full functionality"
+}
+
+post_upgrade() {
+ post_install
+}