summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaylor Smock2015-07-22 05:40:49 -0600
committerTaylor Smock2015-07-22 05:40:49 -0600
commitb4e7ab1ce1a1be74c0f102957ec8589a10134ec8 (patch)
tree29441162625f7443b2b361beb4ddca8b2398314c
downloadaur-b4e7ab1ce1a1be74c0f102957ec8589a10134ec8.tar.gz
Initial commit for Steam Curses
-rw-r--r--.MTREEbin0 -> 301 bytes
-rw-r--r--.PKGINFO23
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
-rw-r--r--changelog.txt5
5 files changed, 79 insertions, 0 deletions
diff --git a/.MTREE b/.MTREE
new file mode 100644
index 000000000000..97332e330731
--- /dev/null
+++ b/.MTREE
Binary files differ
diff --git a/.PKGINFO b/.PKGINFO
new file mode 100644
index 000000000000..4a1e4dee958d
--- /dev/null
+++ b/.PKGINFO
@@ -0,0 +1,23 @@
+# Generated by makepkg 4.2.1
+# using fakeroot version 1.20.2
+# Wed Jul 22 11:33:37 UTC 2015
+pkgname = steamcurses
+pkgver = 8c106e6-1
+pkgdesc = Steam Ncurses for both native and wine versions
+url = https://github.com/TOTBWF/SteamCurses
+builddate = 1437564817
+packager = Taylor Smock <smocktaylor@gmail.com>
+size = 14336
+arch = x86_64
+license = MIT
+depend = steam
+depend = ncurses
+makepkgopt = strip
+makepkgopt = docs
+makepkgopt = !libtool
+makepkgopt = !staticlibs
+makepkgopt = emptydirs
+makepkgopt = zipman
+makepkgopt = purge
+makepkgopt = !upx
+makepkgopt = !debug
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c1cc768bf9dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = steamcurses-git
+ pkgdesc = Steam Ncurses for both native and wine versions
+ pkgver = 8c106e6
+ pkgrel = 1
+ url = https://github.com/TOTBWF/SteamCurses
+ changelog = changelog.txt
+ arch = i686
+ arch = x86_64
+ license = MIT
+ depends = steam
+ depends = ncurses
+ provides = steamcurses
+ conflicts = steamcurses
+ source = git+https://github.com/TOTBWF/SteamCurses.git
+ sha256sums = SKIP
+
+pkgname = steamcurses-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3facc9d443b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: vorpalblade77@gmail.com
+
+pkgname=steamcurses-git
+_pkgname=${pkgname%-git}
+_srcname=SteamCurses
+pkgver=8c106e6
+pkgrel=1
+pkgdesc="Steam Ncurses for both native and wine versions"
+arch=('i686' 'x86_64')
+url="https://github.com/TOTBWF/SteamCurses"
+license=('MIT')
+depends=('steam' 'ncurses')
+# makedepends=('ncurses-devel')
+provides=('steamcurses')
+conflicts=('steamcurses')
+changelog=changelog.txt
+source=('git+https://github.com/TOTBWF/SteamCurses.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_srcname}"
+ git describe --always | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+build() {
+ cd "${srcdir}/${_srcname}"
+ make ${MAKEFLAGS}
+}
+
+package() {
+ # No make install available now
+ mkdir --parent "${pkgdir}/usr/bin"
+ cp "${srcdir}/${_srcname}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
+}
diff --git a/changelog.txt b/changelog.txt
new file mode 100644
index 000000000000..677cd57fded8
--- /dev/null
+++ b/changelog.txt
@@ -0,0 +1,5 @@
+# Changelog for git versions. Major items only
+
+* Wine Steam support
+* Sorting on game list
+* Steam starts in silent mode