summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-03-20 10:01:16 +0800
committerzxp198210052024-03-20 10:01:16 +0800
commit784a8461ab57fa6479e9df21aee84534f5c155a1 (patch)
tree2633c8c716bc90df669f9d0f7091b347ccc59467
parente3a7bb5907f688ff658e1224e0475dac2336580e (diff)
downloadaur-784a8461ab57fa6479e9df21aee84534f5c155a1.tar.gz
fix errors
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
-rw-r--r--steamdepotdownloadergui.sh5
3 files changed, 8 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d18ac12d4f1a..a34f63d8d509 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = steamdepotdownloadergui-bin
pkgdesc = Easily download older versions of games from Steam using DepotDownloader
pkgver = 2.4.1
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/mmvanheusden/SteamDepotDownloaderGUI
arch = aarch64
arch = x86_64
license = GPL-3.0-only
makedepends = fuse2
depends = electron28
- depends = hicolor-icon-theme
provides = steamdepotdownloadergui=2.4.1
conflicts = steamdepotdownloadergui
source = steamdepotdownloadergui.sh
- sha256sums = 50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe
+ sha256sums = dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8
source_aarch64 = steamdepotdownloadergui-2.4.1-aarch64.AppImage::https://github.com/mmvanheusden/SteamDepotDownloaderGUI/releases/download/v2.4.1/SteamDepotDownloaderGUI-linux-2.4.1-arm64.AppImage
sha256sums_aarch64 = 2431e58e3e870e71ec047673f673d3897872d0d245c5aff92635ba90e0412d97
source_x86_64 = steamdepotdownloadergui-2.4.1-x86_64.AppImage::https://github.com/mmvanheusden/SteamDepotDownloaderGUI/releases/download/v2.4.1/SteamDepotDownloaderGUI-linux-2.4.1-x64.AppImage
diff --git a/PKGBUILD b/PKGBUILD
index c98f4bf5db60..100db29bf540 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=steamdepotdownloadergui-bin
_pkgname=SteamDepotDownloaderGUI
pkgver=2.4.1
_electronversion=28
-pkgrel=3
+pkgrel=4
pkgdesc="Easily download older versions of games from Steam using DepotDownloader"
arch=(
'aarch64'
@@ -15,7 +15,6 @@ conflicts=("${pkgname%-bin}")
provides=("${pkgname%-bin}=${pkgver}")
depends=(
"electron${_electronversion}"
- 'hicolor-icon-theme'
)
makedepends=(
'fuse2'
@@ -23,13 +22,14 @@ makedepends=(
source=("${pkgname%-bin}.sh")
source_aarch64=("${pkgname%-bin}-${pkgver}-aarch64.AppImage::${url}/releases/download/v${pkgver}/${_pkgname}-linux-${pkgver}-arm64.AppImage")
source_x86_64=("${pkgname%-bin}-${pkgver}-x86_64.AppImage::${url}/releases/download/v${pkgver}/${_pkgname}-linux-${pkgver}-x64.AppImage")
-sha256sums=('50b10386d13e5bec806aeb78f819c4edd0208a4d184332e53866c802731217fe')
+sha256sums=('dc0c5ca385ad81a08315a91655c7c064b5bf110eada55e61265633ae198b39f8')
sha256sums_aarch64=('2431e58e3e870e71ec047673f673d3897872d0d245c5aff92635ba90e0412d97')
sha256sums_x86_64=('cd8a00d44b174b33d394997b56347d44b1a9f68b4d8c2444bd9401de4a2df0f0')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|app.asar|g" \
+ -e "s|@options@||g" \
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}-${CARCH}.AppImage" --appimage-extract > /dev/null
diff --git a/steamdepotdownloadergui.sh b/steamdepotdownloadergui.sh
index 86cb3dc6a9bf..7ddcaab8d734 100644
--- a/steamdepotdownloadergui.sh
+++ b/steamdepotdownloadergui.sh
@@ -2,6 +2,7 @@
set -e
_APPDIR="/usr/lib/@appname@"
_RUNNAME="${_APPDIR}/@runname@"
+_OPTIONS="@options@"
export PATH="${_APPDIR}:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/swiftshader:${_APPDIR}/lib:${LD_LIBRARY_PATH}"
export ELECTRON_IS_DEV=0
@@ -9,7 +10,7 @@ export ELECTRON_FORCE_IS_PACKAGED=true
export NODE_ENV=production
cd "${_APPDIR}"
if [[ $EUID -ne 0 ]] || [[ $ELECTRON_RUN_AS_NODE ]]; then
- exec electron@electronversion@ "${_RUNNAME}" "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" "$@" || exit $?
else
- exec electron@electronversion@ "${_RUNNAME}" --no-sandbox "$@" || exit $?
+ exec electron@electronversion@ "${_RUNNAME}" "${_OPTIONS}" --no-sandbox "$@" || exit $?
fi \ No newline at end of file