summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOmar Pakker2017-06-18 16:10:55 +0200
committerOmar Pakker2017-06-18 16:10:55 +0200
commitc36793423af34facd657ca98c65a2f2375931198 (patch)
tree6048fd8b027081cc401833f84c271b61e984a062
downloadaur-c36793423af34facd657ca98c65a2f2375931198.tar.gz
Initial push for SteamFootBridge, the python implementation replacing SteamBridge.
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..07fbe950dce3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = steamfootbridge-git
+ pkgdesc = Allows running Steam applications in WINE, while using the native Steam client.
+ pkgver = r25.eb908b4
+ pkgrel = 1
+ url = https://github.com/sirnuke/steamfootbridge
+ arch = any
+ license = MIT
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python-steamodd
+ provides = steamfootbridge
+ conflicts = steamfootbridge
+ replaces = steambridge
+ source = git+https://github.com/sirnuke/steamfootbridge.git
+ sha256sums = SKIP
+
+pkgname = steamfootbridge-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..542b66992b81
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Omar Pakker <archlinux@opakker.nl>
+
+_pkgname=steamfootbridge
+pkgname=steamfootbridge-git
+pkgver=r25.eb908b4
+pkgrel=1
+pkgdesc="Allows running Steam applications in WINE, while using the native Steam client."
+url="https://github.com/sirnuke/steamfootbridge"
+makedepends=('git' 'python-setuptools')
+depends=('python-steamodd')
+provides=('steamfootbridge')
+conflicts=('steamfootbridge')
+replaces=('steambridge')
+license=('MIT')
+arch=('any')
+source=("git+https://github.com/sirnuke/steamfootbridge.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${_pkgname}"
+ python3 setup.py build
+}
+
+package() {
+ cd "${_pkgname}"
+ python3 setup.py install --root="$pkgdir/" --optimize=1
+}