summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxomachine2018-02-02 21:32:05 +0300
committerxomachine2018-02-02 21:37:34 +0300
commit3e0ec3681c256c1b1d084ad546ddfe8b6e93e46a (patch)
treeafbed9fb1bf62c66ea6eca0aff3c3790ebd56fb5
downloadaur-3e0ec3681c256c1b1d084ad546ddfe8b6e93e46a.tar.gz
Added PKGBUILD and .SRCINFO for steamforwarder-git
The SteamForwarder devel branch contains unstable but ready for testing features. At the moment of this commit it contains completely rewritten implementation of SteamForwarder that relies on the devel version of the Nim compiler.
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD42
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97b2cc08048d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = steamforwarder-git
+ pkgdesc = Tool that allows interaction between windows games under wine and the linux steam. (Cutting edge experimental features)
+ pkgver = r141.92e25ce
+ pkgrel = 1
+ epoch = 1
+ url = https://github.com/xomachine/SteamForwarder
+ arch = x86_64
+ arch = i686
+ license = MIT
+ depends = python
+ depends = steam
+ depends = nim-git
+ depends = binutils
+ depends = wine
+ optdepends = steamcmd
+ provides = steamforwarder
+ source = git+https://github.com/xomachine/SteamForwarder.git#branch=devel
+ sha256sums = SKIP
+
+pkgname = steamforwarder-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7c09f0ac50c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Dmitriy Fomichev <xomachiner@gmail.com>
+
+pkgname=('steamforwarder-git')
+_pkgname=SteamForwarder
+pkgdesc="Tool that allows interaction between windows games under wine and the linux steam. (Cutting edge experimental features)"
+pkgver=r141.92e25ce
+pkgrel=1
+epoch=1
+arch=('x86_64' 'i686')
+url="https://github.com/xomachine/SteamForwarder"
+license=('MIT')
+depends=('python' 'steam' 'nim-git' 'binutils' 'wine')
+optdepends=('steamcmd')
+makedepends=()
+provides=('steamforwarder')
+source=("git+https://github.com/xomachine/SteamForwarder.git#branch=devel")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ make tools
+ # Touch required to avoid signatures.txt rebuilding when make install
+ touch signatures.txt
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ make install PREFIX="/usr" DESTDIR="${pkgdir}"
+}
+
+check() {
+ cd "$srcdir/${_pkgname}"
+ make tests
+}