summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gahde2016-09-05 13:08:39 +0200
committerJakob Gahde2016-09-05 13:08:39 +0200
commit245459e9a867cda4cd35f313c33728f7fdf30cf4 (patch)
tree60b3fa5f43d7db1f16e4b4b0e7c04a3ffa6e99c1
parente2a8d85843ee65f1772cb771a9177bdbc929863b (diff)
downloadaur-245459e9a867cda4cd35f313c33728f7fdf30cf4.tar.gz
steamkit 1.8.0-1: New version
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD24
2 files changed, 19 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b434cc49e0f..3dc99a61433c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,18 @@
# Generated by mksrcinfo v8
-# Fri Feb 5 19:17:12 UTC 2016
+# Mon Sep 5 11:07:39 UTC 2016
pkgbase = steamkit
- pkgdesc = A .NET library designed to interoperate with Valve's Steam network. It aims to provide a simple, yet extensible, interface to perform various actions on the network.
- pkgver = 1.7.0
+ pkgdesc = A .NET library designed to interoperate with Valve's Steam network
+ pkgver = 1.8.0
pkgrel = 1
url = https://github.com/SteamRE/SteamKit
arch = any
license = LGPL2.1
+ makedepends = mono<4.4
depends = mono
depends = protobuf-net
options = !strip
- source = https://github.com/SteamRE/SteamKit/archive/SteamKit_1.7.0.tar.gz
- md5sums = 3a1005af9886d3d985f0e40d412d624c
+ source = https://github.com/SteamRE/SteamKit/archive/SteamKit_1.8.0.tar.gz
+ md5sums = 9e88ec62a9c9013f8e4096b19e388deb
pkgname = steamkit
diff --git a/PKGBUILD b/PKGBUILD
index 271c573a3d74..e2dd03567938 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,24 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+
pkgname=steamkit
-pkgver=1.7.0
+pkgver=1.8.0
pkgrel=1
-pkgdesc="A .NET library designed to interoperate with Valve's Steam network. It aims to provide a simple, yet extensible, interface to perform various actions on the network."
+pkgdesc="A .NET library designed to interoperate with Valve's Steam network"
arch=('any')
url="https://github.com/SteamRE/SteamKit"
license=('LGPL2.1')
depends=('mono' 'protobuf-net')
+# Mono >= 4.4 segfaults during the preparations for signing the assembly
+makedepends=('mono<4.4')
options=('!strip')
source=("https://github.com/SteamRE/SteamKit/archive/SteamKit_${pkgver}.tar.gz")
-md5sums=('3a1005af9886d3d985f0e40d412d624c')
+md5sums=('9e88ec62a9c9013f8e4096b19e388deb')
build() {
cd "${srcdir}/SteamKit-SteamKit_${pkgver}/SteamKit2/SteamKit2"
xbuild SteamKit2.csproj /p:Configuration=Release
-
+
cd "bin/Release"
monodis SteamKit2.dll --output=SteamKit2.il
sn -k 1024 SteamKit2.snk
@@ -24,11 +27,10 @@ build() {
package() {
cd "${srcdir}/SteamKit-SteamKit_${pkgver}/SteamKit2/SteamKit2/bin/Release"
-
- install -Dm644 SteamKit2.dll "$pkgdir/usr/lib/SteamKit/SteamKit2.dll"
- install -Dm644 SteamKit2.dll.mdb "$pkgdir/usr/lib/SteamKit/SteamKit2.dll.mdb"
- install -Dm644 changes.txt "$pkgdir/usr/lib/doc/SteamKit/changes.txt"
-
- gacutil -i SteamKit2.dll -root "$pkgdir/usr/lib"
+
+ install -Dm644 SteamKit2.dll "${pkgdir}/usr/lib/SteamKit/SteamKit2.dll"
+ install -Dm644 SteamKit2.dll.mdb "${pkgdir}/usr/lib/SteamKit/SteamKit2.dll.mdb"
+
+ gacutil -i SteamKit2.dll -root "${pkgdir}/usr/lib"
}
-
+