summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ5lx2015-07-03 16:49:12 +0200
committerJ5lx2015-07-03 16:49:12 +0200
commitea9ccd66deeff32434572e8a0a6cf4d01015a4df (patch)
tree3c9e5b501833ce8a55f4b7e20c97f7a98b8966fb
downloadaur-ea9ccd66deeff32434572e8a0a6cf4d01015a4df.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..65b2d7a17f15
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = steamkit
+ pkgdesc = A .NET library designed to interoperate with Valve's Steam network. It aims to provide a simple, yet extensible, interface to perform various actions on the network.
+ pkgver = 1.6.2
+ pkgrel = 1
+ url = https://github.com/SteamRE/SteamKit
+ arch = any
+ license = LGPL2.1
+ depends = mono
+ depends = protobuf-net
+ options = !strip
+ source = https://github.com/SteamRE/SteamKit/archive/SteamKit_1.6.2.tar.gz
+ md5sums = 4c2fe9cc8725e3b080b33c366e558784
+
+pkgname = steamkit
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..50cbb8086e3f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+pkgname=steamkit
+pkgver=1.6.2
+pkgrel=1
+pkgdesc="A .NET library designed to interoperate with Valve's Steam network. It aims to provide a simple, yet extensible, interface to perform various actions on the network."
+arch=('any')
+url="https://github.com/SteamRE/SteamKit"
+license=('LGPL2.1')
+depends=('mono' 'protobuf-net')
+options=('!strip')
+source=("https://github.com/SteamRE/SteamKit/archive/SteamKit_${pkgver}.tar.gz")
+md5sums=('4c2fe9cc8725e3b080b33c366e558784')
+
+build() {
+ cd "${srcdir}/SteamKit-SteamKit_${pkgver}/SteamKit2/SteamKit2"
+
+ xbuild SteamKit2.csproj /p:Configuration=Release
+
+ cd "bin/Release"
+ monodis SteamKit2.dll --output=SteamKit2.il
+ sn -k 1024 SteamKit2.snk
+ ilasm /dll /key:SteamKit2.snk SteamKit2.il
+}
+
+package() {
+ cd "${srcdir}/SteamKit-SteamKit_${pkgver}/SteamKit2/SteamKit2/bin/Release"
+
+ install -Dm644 SteamKit2.dll "$pkgdir/usr/lib/SteamKit/SteamKit2.dll"
+ install -Dm644 SteamKit2.dll.mdb "$pkgdir/usr/lib/SteamKit/SteamKit2.dll.mdb"
+ install -Dm644 changes.txt "$pkgdir/usr/lib/doc/SteamKit/changes.txt"
+
+ gacutil -i SteamKit2.dll -root "$pkgdir/usr/lib"
+}
+