summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDor Askayo2016-08-08 03:10:50 +0300
committerDor Askayo2016-08-08 03:12:59 +0300
commitbcbf87af98511b1e6e64986d83fd4a9e94d8e292 (patch)
tree397177fb7b8fe844eefe17740d28a45824aaa2fc
downloadaur-bcbf87af98511b1e6e64986d83fd4a9e94d8e292.tar.gz
addpkg: steamrun 0.1.0
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD22
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..659638e873f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = steamrun
+ pkgdesc = A simple script for executing programs in the Steam Runtime
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/doraskayo/steamrun
+ arch = any
+ license = MIT
+ depends = steam
+ source = https://github.com/doraskayo/steamrun/archive/0.1.0.tar.gz
+ sha256sums = 4f71118c53d0a2d85d91218587261cfa32036a93c575c6a5a3695e5987369512
+
+pkgname = steamrun
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cb99891d41a7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Dor Askayo <dor.askayo@gmail.com>
+
+pkgname=steamrun
+pkgver=0.1.0
+pkgrel=1
+pkgdesc='A simple script for executing programs in the Steam Runtime'
+arch=('any')
+url='https://github.com/doraskayo/steamrun'
+license=('MIT')
+depends=('steam')
+source=("https://github.com/doraskayo/steamrun/archive/${pkgver}.tar.gz")
+sha256sums=('4f71118c53d0a2d85d91218587261cfa32036a93c575c6a5a3695e5987369512')
+
+package() {
+ cd "$srcdir/steamrun-$pkgver"
+
+ # Install the script
+ install -D "$pkgname" "$pkgdir/usr/bin/$pkgname"
+
+ # Install the license
+ install -Dm644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}