summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlan Jenkins2020-07-04 10:55:59 +0100
committerAlan Jenkins2020-07-04 10:58:56 +0100
commit36edc041d9a9abe8faf9718ce5779e974c2e7bdf (patch)
tree191b2a3fb4873417cf4f59894516d5ce20009769
downloadaur-36edc041d9a9abe8faf9718ce5779e974c2e7bdf.tar.gz
Initial version (no git tagged versions)
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a443be751811
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = steamtinkerlaunch
+ pkgdesc = SteamTinkerLaunch or short stl - is a linux wrapper script for steam. It creates/reads game config files on the fly, making it very easy to setup and use, but still giving you the possibility to fully customize game configurations live on game start.
+ pkgver = c1f6d094b7c5456211bed42dfa5ac62253670e84
+ pkgrel = 1
+ url = https://github.com/frostworx/steamtinkerlaunch
+ arch = any
+ license = GPL3
+ depends = bash
+ backup = etc/sshuttle/tunnel.conf
+ backup = etc/sshuttle/prefixes.conf
+ source = git+https://github.com/frostworx/steamtinkerlaunch.git
+ sha1sums = SKIP
+
+pkgname = steamtinkerlaunch
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3e843d9e18fa
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.pkg.tar.*
+steamtinkerlaunch/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed904a832635
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Alan Jenkins <alan.james.jenkins@gmail.com>
+
+pkgname=steamtinkerlaunch
+pkgver=c1f6d094b7c5456211bed42dfa5ac62253670e84
+#_commit=e433c599e40bc47c7b0e4d16934815c84b26eea8
+pkgrel=1
+pkgdesc='SteamTinkerLaunch or short stl - is a linux wrapper script for steam. It creates/reads game config files on the fly, making it very easy to setup and use, but still giving you the possibility to fully customize game configurations live on game start.'
+arch=('any')
+url="https://github.com/frostworx/steamtinkerlaunch"
+license=('GPL3')
+depends=('bash')
+backup=('etc/sshuttle/tunnel.conf' 'etc/sshuttle/prefixes.conf')
+source=("git+https://github.com/frostworx/steamtinkerlaunch.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ cat .git/refs/heads/master
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+
+ # Make directories to install into
+ install -d "$pkgdir/usr/local/share/stl"
+ install -d "$pkgdir/usr/local/bin"
+
+ # Install package files
+ install -m755 "stl" "$pkgdir/usr/local/bin/stl"
+
+ find . -maxdepth 1 -type d -not -name '.git' -and -not -name '.' -print0 | xargs -i'{}' -0 cp -R {} "$pkgdir/usr/local/share/stl"
+}