summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrostworx2020-10-06 10:54:45 +0200
committerfrostworx2020-10-06 10:54:45 +0200
commit3ba8a5761444a2182c894e38322d8e354aa4dc2b (patch)
tree863d56d59b91d23cd6d42f51b38467e0e6cf89f7
parent58d36d495ad7129515ffad5e2bcf7e94bd3f76c0 (diff)
downloadaur-3ba8a5761444a2182c894e38322d8e354aa4dc2b.tar.gz
update to v2.2.2
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 983ebc2a70f3..e1df0bfd4758 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,38 +1,38 @@
pkgbase = steamtinkerlaunch
pkgdesc = Wrapper script for Steam custom launch options
- pkgver = 2.0.7
+ pkgver = 2.2.2
pkgrel = 1
url = https://github.com/frostworx/steamtinkerlaunch
arch = any
license = GPL3
depends = bash
+ depends = git
+ depends = unzip
+ depends = wget
+ depends = wmctrl
+ depends = xdotool
+ depends = xorg-xprop
+ depends = xorg-xrandr
+ depends = xorg-xwininfo
+ depends = yad
optdepends = strace: write a strace log of the launched game
optdepends = gamemode: for using GameMode per game
optdepends = mangohud: for using MangoHUD per game
optdepends = vkbasalt: for using vkBasalt per game
optdepends = winetricks: winetricks support
- optdepends = wget: for optional reshade download
- optdepends = unzip: for optional reshade download
- optdepends = git: for pulling optional shaders
- optdepends = xdotool: for playing regular games side-by-side in VR
- optdepends = xorg-xwininfo: for playing regular games side-by-side in VR and for automatic resolution detection
optdepends = vr-video-player: for playing regular games side-by-side in VR
optdepends = nyrna: for using Nyrna per game
optdepends = replay-sorcery: for using Replay-Sorcery per game
- optdepends = wmctrl: for optional minimize/maximize of all open windows on game start/stop
optdepends = net-tools: for optional network monitoring
optdepends = boxtron: for optional Boxtron support
optdepends = scummvm: for optional ScummVM support via Roberta
optdepends = wine: for optional Vortex Mod Manager support
optdepends = gameconqueror: for optional cheating
- optdepends = xorg-xprop: for optional window toggle and side-by-side VR
optdepends = gamescope: for optional GameScope support
optdepends = libnotify: for optional Notifier
- optdepends = yad: for the optional Settings Menu
optdepends = zenity: optional for the Editor Dialog
- optdepends = xorg-xrandr: optional for automatic resolution detection
- source = steamtinkerlaunch-2.0.7.tar.gz::https://github.com/frostworx/steamtinkerlaunch/archive/v2.0.7.tar.gz
- sha256sums = e86b96f7dcc5f09147d3e6ac4afa002b079d9e3e031ee9fefd268d2d103219ed
+ source = steamtinkerlaunch-2.2.2.tar.gz::https://github.com/frostworx/steamtinkerlaunch/archive/v2.2.2.tar.gz
+ sha256sums = cb5bed1e0a3fc0cd0eb47db82e11954b68bb973e4806a42f451310dcddf43209
pkgname = steamtinkerlaunch
diff --git a/PKGBUILD b/PKGBUILD
index 7bde6cad1f6e..a511c2813405 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,45 +2,34 @@
# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Co-Maintainer: Marcel Unbehaun <f.rostze.ux at gmail dot com>
pkgname=steamtinkerlaunch
-pkgver=2.0.7
+pkgver=2.2.2
pkgrel=1
pkgdesc="Wrapper script for Steam custom launch options"
arch=('any')
url="https://github.com/frostworx/steamtinkerlaunch"
license=('GPL3')
-depends=(
- 'bash'
-)
+depends=('bash' 'git' 'unzip' 'wget' 'wmctrl' 'xdotool' 'xorg-xprop' 'xorg-xrandr' 'xorg-xwininfo' 'yad')
optdepends=(
'strace: write a strace log of the launched game'
'gamemode: for using GameMode per game'
'mangohud: for using MangoHUD per game'
'vkbasalt: for using vkBasalt per game'
'winetricks: winetricks support'
- 'wget: for optional reshade download'
- 'unzip: for optional reshade download'
- 'git: for pulling optional shaders'
- 'xdotool: for playing regular games side-by-side in VR'
- 'xorg-xwininfo: for playing regular games side-by-side in VR and for automatic resolution detection'
'vr-video-player: for playing regular games side-by-side in VR'
'nyrna: for using Nyrna per game'
'replay-sorcery: for using Replay-Sorcery per game'
- 'wmctrl: for optional minimize/maximize of all open windows on game start/stop'
'net-tools: for optional network monitoring'
'boxtron: for optional Boxtron support'
'scummvm: for optional ScummVM support via Roberta'
'wine: for optional Vortex Mod Manager support'
'gameconqueror: for optional cheating'
- 'xorg-xprop: for optional window toggle and side-by-side VR'
'gamescope: for optional GameScope support'
'libnotify: for optional Notifier'
- 'yad: for the optional Settings Menu'
'zenity: optional for the Editor Dialog'
- 'xorg-xrandr: optional for automatic resolution detection'
)
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('e86b96f7dcc5f09147d3e6ac4afa002b079d9e3e031ee9fefd268d2d103219ed')
+sha256sums=('cb5bed1e0a3fc0cd0eb47db82e11954b68bb973e4806a42f451310dcddf43209')
package() {
cd "$srcdir/$pkgname-${pkgver}"