summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrostworx2020-08-03 12:52:15 +0200
committerfrostworx2020-08-03 12:52:15 +0200
commit434e67b5e98d047a741da3761935d3b45898b613 (patch)
tree72e3a6605de143564c8ba9e9a66072a9797ed4b1
parentaff6b82cbe58abecc22637cf8e27627b82949419 (diff)
downloadaur-434e67b5e98d047a741da3761935d3b45898b613.tar.gz
update to v1.0.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD18
2 files changed, 10 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3afa08abd39b..f2c0d5be3752 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,11 +1,10 @@
pkgbase = steamtinkerlaunch
pkgdesc = Wrapper script for Steam custom launch options
- pkgver = 0.99.9
- pkgrel = 2
+ pkgver = 1.0.0
+ pkgrel = 1
url = https://github.com/frostworx/steamtinkerlaunch
arch = any
license = GPL3
- makedepends = git
depends = bash
optdepends = strace: write a strace log of the launched game
optdepends = gamemode: for using GameMode per game
@@ -22,8 +21,8 @@ pkgbase = steamtinkerlaunch
optdepends = replay-sorcery: for using Replay-Sorcery per game
optdepends = wmctrl: for optional minimize/maximize of all open windows on game start/stop
optdepends = net-tools: for optional network monitoring
- source = git+https://github.com/frostworx/steamtinkerlaunch.git#commit=a90f65e06e2a2e121f11530f182f573611ea2433
- sha1sums = SKIP
+ source = https://github.com/frostworx/steamtinkerlaunch/archive/v1.0.0.tar.gz
+ md5sums = 76ec63eba0fb33a2851d52de30f972a2
pkgname = steamtinkerlaunch
diff --git a/PKGBUILD b/PKGBUILD
index 51879c584cc3..6d4c2812c1e3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,13 @@
# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Co-Maintainer: Marcel Unbehaun <f.rostze.ux at gmail dot com>
pkgname=steamtinkerlaunch
-pkgver=0.99.9
-pkgrel=2
+pkgver=1.0.0
+pkgrel=1
pkgdesc="Wrapper script for Steam custom launch options"
arch=('any')
url="https://github.com/frostworx/steamtinkerlaunch"
license=('GPL3')
depends=('bash')
-makedepends=('git')
optdepends=(
'strace: write a strace log of the launched game'
'gamemode: for using GameMode per game'
@@ -27,21 +26,16 @@ optdepends=(
'wmctrl: for optional minimize/maximize of all open windows on game start/stop'
'net-tools: for optional network monitoring'
)
-_commit='a90f65e06e2a2e121f11530f182f573611ea2433'
-source=("git+https://github.com/frostworx/steamtinkerlaunch.git#commit=$_commit")
-sha1sums=('SKIP')
-pkgver() {
- cd "$srcdir/$pkgname"
- printf $(grep 'PROGVERS=' stl | head -n1 | cut -d\" -f2 | sed 's/^v//')
-}
+source=("https://github.com/frostworx/$pkgname/archive/v${pkgver}.tar.gz")
+md5sums=('76ec63eba0fb33a2851d52de30f972a2')
package() {
- cd "$srcdir/$pkgname"
+ cd "$srcdir/$pkgname-${pkgver}"
install -Dm755 stl -t "$pkgdir/usr/bin"
install -d "$pkgdir/usr/share/stl"
- cp -r sbs tweaks "$pkgdir/usr/share/stl"
+ cp -r regs sbs tweaks "$pkgdir/usr/share/stl"
install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
}