summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrostworx2020-10-13 13:10:56 +0200
committerfrostworx2020-10-13 13:10:56 +0200
commit493c788e3775475b3dea04d703f447e9c1b97a63 (patch)
tree1b198eeb232ee3ac4d5441a9e803fb0bc9b4ba6d
parentb263f6122af6d4647a043cfa6136f83f5acfe5c8 (diff)
downloadaur-493c788e3775475b3dea04d703f447e9c1b97a63.tar.gz
update to v2.3.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c525895d54bb..cd532db63c7f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = steamtinkerlaunch
pkgdesc = Wrapper script for Steam custom launch options
- pkgver = 2.2.3
+ pkgver = 2.3.0
pkgrel = 1
url = https://github.com/frostworx/steamtinkerlaunch
arch = any
@@ -31,8 +31,10 @@ pkgbase = steamtinkerlaunch
optdepends = gamescope: for optional GameScope support
optdepends = libnotify: for optional Notifier
optdepends = zenity: optional for the Editor Dialog
- source = steamtinkerlaunch-2.2.3.tar.gz::https://github.com/frostworx/steamtinkerlaunch/archive/v2.2.3.tar.gz
- sha256sums = 14d3a09921b231638a6160d387a3aade3f5e0285f25a3c1618bfa4db57776114
+ optdepends = cabextract: optional for extracting the wmp10 setup archive
+ optdepends = usbutils: optional for a quick VR HMD presence check
+ source = steamtinkerlaunch-2.3.0.tar.gz::https://github.com/frostworx/steamtinkerlaunch/archive/v2.3.0.tar.gz
+ sha256sums = 8b213a28135357ccdee9d09be49fcc673cb93e01bfd19c496240461829398f60
pkgname = steamtinkerlaunch
diff --git a/PKGBUILD b/PKGBUILD
index b9e6d92bf74c..4dbff2e6aee3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Co-Maintainer: Marcel Unbehaun <f.rostze.ux at gmail dot com>
pkgname=steamtinkerlaunch
-pkgver=2.2.3
+pkgver=2.3.0
pkgrel=1
pkgdesc="Wrapper script for Steam custom launch options"
arch=('any')
@@ -26,17 +26,19 @@ optdepends=(
'gamescope: for optional GameScope support'
'libnotify: for optional Notifier'
'zenity: optional for the Editor Dialog'
+ 'cabextract: optional for extracting the wmp10 setup archive'
+ 'usbutils: optional for a quick VR HMD presence check'
)
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('14d3a09921b231638a6160d387a3aade3f5e0285f25a3c1618bfa4db57776114')
+sha256sums=('8b213a28135357ccdee9d09be49fcc673cb93e01bfd19c496240461829398f60')
package() {
cd "$srcdir/$pkgname-${pkgver}"
install -Dm755 stl -t "$pkgdir/usr/bin"
install -d "$pkgdir/usr/share/stl"
- cp -r categories misc regs tweaks "$pkgdir/usr/share/stl"
+ cp -r categories lang misc regs tweaks "$pkgdir/usr/share/stl"
install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
}