summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlan Jenkins2023-01-02 16:43:25 +0000
committerAlan Jenkins2023-01-02 16:43:25 +0000
commit52ddb192e4df4995bc677ad0c4c0a927492117b1 (patch)
tree46cfba06e2acf61425dc14481e0538d70863a426
parenta5a84a43c7a2ffe6d362d0731b88b9765f3d1957 (diff)
downloadaur-52ddb192e4df4995bc677ad0c4c0a927492117b1.tar.gz
Remove optional dependency gameconqueror
-rw-r--r--.SRCINFO35
-rw-r--r--PKGBUILD35
2 files changed, 34 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d99ce152ff89..3dffb4ca4287 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = steamtinkerlaunch
pkgdesc = Wrapper script for Steam custom launch options
pkgver = 12.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/sonic2kk/steamtinkerlaunch
arch = any
license = GPL3
@@ -16,29 +16,28 @@ pkgbase = steamtinkerlaunch
depends = xorg-xrandr
depends = xorg-xwininfo
depends = yad
- optdepends = strace: write a strace log of the launched game
- optdepends = gamemode: for using GameMode per game
- optdepends = mangohud: for using MangoHUD per game
- optdepends = vkbasalt: for using vkBasalt per game
- optdepends = winetricks: winetricks support
- optdepends = vr-video-player: for playing regular games side-by-side in VR
- optdepends = nyrna: for using Nyrna per game
- optdepends = replay-sorcery: for using Replay-Sorcery per game
- optdepends = net-tools: for optional network monitoring
optdepends = boxtron: for optional Boxtron support
- optdepends = scummvm: for optional ScummVM support via Roberta
- optdepends = wine: for optional wine support
- optdepends = gameconqueror: for optional cheating
+ optdepends = gamemode: for using GameMode per game
optdepends = gamescope: for optional GameScope support
- optdepends = libnotify: for optional Notifier
+ optdepends = gdb: optional for starting the game under the debugger gdb
+ optdepends = imagemagick: optional to scale a custom installed game header picture and for converting game icons
optdepends = innoextract: optional for extracting the Cheat Engine setup archive
- optdepends = usbutils: optional for a quick VR HMD presence check
optdepends = jq: optional for extracting game names from the steam api
- optdepends = rsync: optional for backing up steamuser files from proton games
- optdepends = imagemagick: optional to scale a custom installed game header picture and for converting game icons
+ optdepends = libnotify: for optional Notifier
+ optdepends = mangohud: for using MangoHUD per game
+ optdepends = net-tools: for optional network monitoring
+ optdepends = nyrna: for using Nyrna per game
optdepends = p7zip: optional for extracting SpecialK archives
optdepends = pev: optional for extracting data from the game exe
- optdepends = gdb: optional for starting the game under the debugger gdb
+ optdepends = replay-sorcery: for using Replay-Sorcery per game
+ optdepends = rsync: optional for backing up steamuser files from proton games
+ optdepends = scummvm: for optional ScummVM support via Roberta
+ optdepends = strace: write a strace log of the launched game
+ optdepends = usbutils: optional for a quick VR HMD presence check
+ optdepends = vkbasalt: for using vkBasalt per game
+ optdepends = vr-video-player: for playing regular games side-by-side in VR
+ optdepends = wine: for optional wine support
+ optdepends = winetricks: winetricks support
optdepends = xdg-utils: optional for opening game paths
source = steamtinkerlaunch-12.0.tar.gz::https://github.com/sonic2kk/steamtinkerlaunch/archive/v12.0.tar.gz
sha256sums = c20dabbf08722a3da207e6b5eaf515b5ca76c25138345940df689d5250c60e04
diff --git a/PKGBUILD b/PKGBUILD
index 52c4c36caf36..be0091483202 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,36 +3,35 @@
# Contributor: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=steamtinkerlaunch
pkgver=12.0
-pkgrel=1
+pkgrel=2
pkgdesc="Wrapper script for Steam custom launch options"
arch=('any')
url="https://github.com/sonic2kk/steamtinkerlaunch"
license=('GPL3')
depends=('bash' 'git' 'procps-ng' 'unzip' 'xxd' 'wget' 'xdotool' 'xorg-xprop' 'xorg-xrandr' 'xorg-xwininfo' 'yad')
optdepends=(
- 'strace: write a strace log of the launched game'
- 'gamemode: for using GameMode per game'
- 'mangohud: for using MangoHUD per game'
- 'vkbasalt: for using vkBasalt per game'
- 'winetricks: winetricks support'
- 'vr-video-player: for playing regular games side-by-side in VR'
- 'nyrna: for using Nyrna per game'
- 'replay-sorcery: for using Replay-Sorcery per game'
- 'net-tools: for optional network monitoring'
'boxtron: for optional Boxtron support'
- 'scummvm: for optional ScummVM support via Roberta'
- 'wine: for optional wine support'
- 'gameconqueror: for optional cheating'
+ 'gamemode: for using GameMode per game'
'gamescope: for optional GameScope support'
- 'libnotify: for optional Notifier'
+ 'gdb: optional for starting the game under the debugger gdb'
+ 'imagemagick: optional to scale a custom installed game header picture and for converting game icons'
'innoextract: optional for extracting the Cheat Engine setup archive'
- 'usbutils: optional for a quick VR HMD presence check'
'jq: optional for extracting game names from the steam api'
- 'rsync: optional for backing up steamuser files from proton games'
- 'imagemagick: optional to scale a custom installed game header picture and for converting game icons'
+ 'libnotify: for optional Notifier'
+ 'mangohud: for using MangoHUD per game'
+ 'net-tools: for optional network monitoring'
+ 'nyrna: for using Nyrna per game'
'p7zip: optional for extracting SpecialK archives'
'pev: optional for extracting data from the game exe'
- 'gdb: optional for starting the game under the debugger gdb'
+ 'replay-sorcery: for using Replay-Sorcery per game'
+ 'rsync: optional for backing up steamuser files from proton games'
+ 'scummvm: for optional ScummVM support via Roberta'
+ 'strace: write a strace log of the launched game'
+ 'usbutils: optional for a quick VR HMD presence check'
+ 'vkbasalt: for using vkBasalt per game'
+ 'vr-video-player: for playing regular games side-by-side in VR'
+ 'wine: for optional wine support'
+ 'winetricks: winetricks support'
'xdg-utils: optional for opening game paths'
)