summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrostworx2020-10-27 09:50:08 +0100
committerfrostworx2020-10-27 09:50:08 +0100
commit87aca9860157d4000822ef6659951596f73f6df6 (patch)
tree310115c665cdecfedf91c28ba7e2dab73c2ac08e
parent13235602ce794d65206bf9718fadbbdd2044ffde (diff)
downloadaur-87aca9860157d4000822ef6659951596f73f6df6.tar.gz
update to v2.6.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD7
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f070108a111..0b0631f4a1e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = steamtinkerlaunch
pkgdesc = Wrapper script for Steam custom launch options
- pkgver = 2.4.1
+ pkgver = 2.6.0
pkgrel = 1
url = https://github.com/frostworx/steamtinkerlaunch
arch = any
license = GPL3
depends = bash
depends = git
+ depends = procps-ng
depends = unzip
depends = wget
+ depends = which
depends = wmctrl
depends = xdotool
depends = xorg-xprop
@@ -33,8 +35,9 @@ pkgbase = steamtinkerlaunch
optdepends = zenity: optional for the Editor Dialog
optdepends = cabextract: optional for extracting the wmp10 setup archive
optdepends = usbutils: optional for a quick VR HMD presence check
- source = steamtinkerlaunch-2.4.1.tar.gz::https://github.com/frostworx/steamtinkerlaunch/archive/v2.4.1.tar.gz
- sha256sums = e050ba5952946e14eb63eb4ca0f628516e8ef68592cc0d466bd4b3189429509d
+ optdepends = jq: optional for extracting game names from the steam api
+ source = steamtinkerlaunch-2.6.0.tar.gz::https://github.com/frostworx/steamtinkerlaunch/archive/v2.6.0.tar.gz
+ sha256sums = e4bbfb7948b68e8bedeceadf4e058c0bb5144c5e4af644f6451e57a80f260034
pkgname = steamtinkerlaunch
diff --git a/PKGBUILD b/PKGBUILD
index d87222df6f0c..ba1cb9c9e8f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
# Co-Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Co-Maintainer: Marcel Unbehaun <f.rostze.ux at gmail dot com>
pkgname=steamtinkerlaunch
-pkgver=2.4.1
+pkgver=2.6.0
pkgrel=1
pkgdesc="Wrapper script for Steam custom launch options"
arch=('any')
url="https://github.com/frostworx/steamtinkerlaunch"
license=('GPL3')
-depends=('bash' 'git' 'unzip' 'wget' 'wmctrl' 'xdotool' 'xorg-xprop' 'xorg-xrandr' 'xorg-xwininfo' 'yad')
+depends=('bash' 'git' 'procps-ng' 'unzip' 'wget' 'which' 'wmctrl' 'xdotool' 'xorg-xprop' 'xorg-xrandr' 'xorg-xwininfo' 'yad')
optdepends=(
'strace: write a strace log of the launched game'
'gamemode: for using GameMode per game'
@@ -28,10 +28,11 @@ optdepends=(
'zenity: optional for the Editor Dialog'
'cabextract: optional for extracting the wmp10 setup archive'
'usbutils: optional for a quick VR HMD presence check'
+ 'jq: optional for extracting game names from the steam api'
)
source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
-sha256sums=('e050ba5952946e14eb63eb4ca0f628516e8ef68592cc0d466bd4b3189429509d')
+sha256sums=('e4bbfb7948b68e8bedeceadf4e058c0bb5144c5e4af644f6451e57a80f260034')
package() {
cd "$srcdir/$pkgname-${pkgver}"