summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrostworx2021-03-01 09:23:57 +0100
committerfrostworx2021-03-01 09:23:57 +0100
commit0d31c368e00bda01e8ae5f76994d506514f90282 (patch)
treeba54f135878bf754b4cc62504a7a3d9283af58e3
parente78e1c4194aff8be78ac5e6d00492ed0b4e73d34 (diff)
downloadaur-0d31c368e00bda01e8ae5f76994d506514f90282.tar.gz
added openssl as optional dependency
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD41
2 files changed, 22 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76e0924df454..44b8e3f45a08 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -37,6 +37,7 @@ pkgbase = steamtinkerlaunch-git
optdepends = usbutils: optional for a quick VR HMD presence check
optdepends = jq: optional for extracting game names from the steam api and for sorting available Lutris Wine Versions
optdepends = rsync: optional for backing up steamuser files from proton games
+ optdepends = openssl: optional for generating a random hex string for Non-Steam games
provides = steamtinkerlaunch
conflicts = steamtinkerlaunch
source = git+https://github.com/frostworx/steamtinkerlaunch.git
diff --git a/PKGBUILD b/PKGBUILD
index 4241ecf46544..88080860b70e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,26 +12,27 @@ license=('GPL3')
depends=('bc' 'bash' 'procps-ng' 'unzip' 'wget' 'which' 'xdotool' 'xorg-xprop' 'xorg-xrandr' 'xorg-xwininfo' 'yad')
makedepends=('git')
optdepends=(
- 'strace: write a strace log of the launched game'
- 'gamemode: for using GameMode per game'
- 'mangohud: for using MangoHUD per game'
- 'vkbasalt: for using vkBasalt per game'
- 'winetricks: winetricks support'
- 'vr-video-player: for playing regular games side-by-side in VR'
- 'nyrna: for using Nyrna per game'
- 'replay-sorcery: for using Replay-Sorcery per game'
- 'net-tools: for optional network monitoring'
- 'boxtron: for optional Boxtron support'
- 'scummvm: for optional ScummVM support via Roberta'
- 'wine: for optional Vortex Mod Manager support'
- 'gameconqueror: for optional cheating'
- 'gamescope: for optional GameScope support'
- 'libnotify: for optional Notifier'
- 'cabextract: optional for extracting the wmp10 setup archive'
- 'innoextract: optional for extracting the Cheat Engine setup archive'
- 'usbutils: optional for a quick VR HMD presence check'
- 'jq: optional for extracting game names from the steam api and for sorting available Lutris Wine Versions'
- 'rsync: optional for backing up steamuser files from proton games'
+ 'strace: write a strace log of the launched game'
+ 'gamemode: for using GameMode per game'
+ 'mangohud: for using MangoHUD per game'
+ 'vkbasalt: for using vkBasalt per game'
+ 'winetricks: winetricks support'
+ 'vr-video-player: for playing regular games side-by-side in VR'
+ 'nyrna: for using Nyrna per game'
+ 'replay-sorcery: for using Replay-Sorcery per game'
+ 'net-tools: for optional network monitoring'
+ 'boxtron: for optional Boxtron support'
+ 'scummvm: for optional ScummVM support via Roberta'
+ 'wine: for optional Vortex Mod Manager support'
+ 'gameconqueror: for optional cheating'
+ 'gamescope: for optional GameScope support'
+ 'libnotify: for optional Notifier'
+ 'cabextract: optional for extracting the wmp10 setup archive'
+ 'innoextract: optional for extracting the Cheat Engine setup archive'
+ 'usbutils: optional for a quick VR HMD presence check'
+ 'jq: optional for extracting game names from the steam api and for sorting available Lutris Wine Versions'
+ 'rsync: optional for backing up steamuser files from proton games'
+ 'openssl: optional for generating a random hex string for Non-Steam games'
)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")