summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlan Jenkins2020-07-04 21:39:11 +0100
committerAlan Jenkins2020-07-04 21:39:11 +0100
commitc2990454c543c07d6d231275690a35df5c2501a6 (patch)
tree9d0f1558d02c32a8c7361e2be2bc2d0507996d04
downloadaur-c2990454c543c07d6d231275690a35df5c2501a6.tar.gz
Initial commit
PKGBUILD contributed by Mark Wagie <mark.wagie@tutanota.com>.
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD46
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d45fd8c0d5a2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = steamtinkerlaunch-git
+ pkgdesc = Wrapper script for Steam custom launch options
+ pkgver = 0.91.r32.c1f6d09
+ pkgrel = 1
+ url = https://github.com/frostworx/steamtinkerlaunch
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = bash
+ optdepends = strace
+ optdepends = zenity
+ optdepends = gamemode
+ optdepends = mangohud
+ optdepends = vkbasalt
+ optdepends = winetricks
+ optdepends = wget: for optional reshade download
+ optdepends = unzip: for optional reshade download
+ optdepends = git: for pulling optional shaders
+ optdepends = xdotool: for playing regular games side-by-side in VR
+ optdepends = xorg-xwininfo: for playing regular games side-by-side in VR
+ optdepends = vr-video-player: for playing regular games side-by-side in VR
+ optdepends = xdg-utils: for opening the ProtonDB URL of started game
+ provides = steamtinkerlaunch
+ conflicts = steamtinkerlaunch
+ source = git+https://github.com/frostworx/steamtinkerlaunch.git
+ sha1sums = SKIP
+
+pkgname = steamtinkerlaunch-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3e843d9e18fa
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.pkg.tar.*
+steamtinkerlaunch/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5140d0ac3d8c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Alan Jenkins <alan.james.jenkins@gmail.com>
+# Contributor: Mark Wagie <mark.wagie@tutanota.com>
+
+pkgname=steamtinkerlaunch-git
+pkgver=0.91.r32.c1f6d09
+pkgrel=1
+pkgdesc="Wrapper script for Steam custom launch options"
+arch=('any')
+url="https://github.com/frostworx/steamtinkerlaunch"
+license=('GPL3')
+depends=('bash')
+makedepends=('git')
+optdepends=(
+ 'strace'
+ 'zenity'
+ 'gamemode'
+ 'mangohud'
+ 'vkbasalt'
+ 'winetricks'
+ 'wget: for optional reshade download'
+ 'unzip: for optional reshade download'
+ 'git: for pulling optional shaders'
+ 'xdotool: for playing regular games side-by-side in VR'
+ 'xorg-xwininfo: for playing regular games side-by-side in VR'
+ 'vr-video-player: for playing regular games side-by-side in VR'
+ 'xdg-utils: for opening the ProtonDB URL of started game'
+)
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/frostworx/steamtinkerlaunch.git')
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s.r%s.%s" \
+ "$(grep 'PROGVERS=' stl | head -n1 | cut -d\" -f2 | sed 's/^v//')" \
+ "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -Dm755 stl -t "$pkgdir/usr/bin"
+
+ install -d "$pkgdir/usr/share/doc/${pkgname%-git}"
+ cp -r *.md sbs tweaks "$pkgdir/usr/share/doc/${pkgname%-git}"
+} \ No newline at end of file