summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfrostworx2021-03-01 09:04:03 +0100
committerfrostworx2021-03-01 09:04:03 +0100
commite78e1c4194aff8be78ac5e6d00492ed0b4e73d34 (patch)
treeb1c9977b6038c603b8d56b84d0ed18b2d9fe45c3
parentd13eb04ffa2df84a6347c4c62cc52c97516fd6b1 (diff)
downloadaur-e78e1c4194aff8be78ac5e6d00492ed0b4e73d34.tar.gz
added latest dependencies
-rw-r--r--.SRCINFO43
-rw-r--r--PKGBUILD39
2 files changed, 53 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f90855524fd..76e0924df454 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,42 @@
pkgbase = steamtinkerlaunch-git
pkgdesc = Wrapper script for Steam custom launch options
pkgver = 4.0_next7.r194.145caa2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/frostworx/steamtinkerlaunch
arch = any
license = GPL3
makedepends = git
+ depends = bc
depends = bash
- optdepends = strace
- optdepends = zenity
- optdepends = gamemode
- optdepends = mangohud
- optdepends = vkbasalt
- optdepends = winetricks
- optdepends = wget: for optional reshade download
- optdepends = unzip: for optional reshade download
- optdepends = git: for pulling optional shaders
- optdepends = xdotool: for playing regular games side-by-side in VR
- optdepends = xorg-xwininfo: for playing regular games side-by-side in VR
+ depends = procps-ng
+ depends = unzip
+ depends = wget
+ depends = which
+ depends = xdotool
+ depends = xorg-xprop
+ depends = xorg-xrandr
+ depends = xorg-xwininfo
+ depends = yad
+ optdepends = strace: write a strace log of the launched game
+ optdepends = gamemode: for using GameMode per game
+ optdepends = mangohud: for using MangoHUD per game
+ optdepends = vkbasalt: for using vkBasalt per game
+ optdepends = winetricks: winetricks support
optdepends = vr-video-player: for playing regular games side-by-side in VR
- optdepends = xdg-utils: for opening the ProtonDB URL of started game
+ optdepends = nyrna: for using Nyrna per game
+ optdepends = replay-sorcery: for using Replay-Sorcery per game
+ optdepends = net-tools: for optional network monitoring
+ optdepends = boxtron: for optional Boxtron support
+ optdepends = scummvm: for optional ScummVM support via Roberta
+ optdepends = wine: for optional Vortex Mod Manager support
+ optdepends = gameconqueror: for optional cheating
+ optdepends = gamescope: for optional GameScope support
+ optdepends = libnotify: for optional Notifier
+ optdepends = cabextract: optional for extracting the wmp10 setup archive
+ optdepends = innoextract: optional for extracting the Cheat Engine setup archive
+ optdepends = usbutils: optional for a quick VR HMD presence check
+ optdepends = jq: optional for extracting game names from the steam api and for sorting available Lutris Wine Versions
+ optdepends = rsync: optional for backing up steamuser files from proton games
provides = steamtinkerlaunch
conflicts = steamtinkerlaunch
source = git+https://github.com/frostworx/steamtinkerlaunch.git
diff --git a/PKGBUILD b/PKGBUILD
index e74a76ab4f1f..4241ecf46544 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,27 +4,34 @@
pkgname=steamtinkerlaunch-git
pkgver=4.0_next7.r194.145caa2
-pkgrel=1
+pkgrel=2
pkgdesc="Wrapper script for Steam custom launch options"
arch=('any')
url="https://github.com/frostworx/steamtinkerlaunch"
license=('GPL3')
-depends=('bash')
+depends=('bc' 'bash' 'procps-ng' 'unzip' 'wget' 'which' 'xdotool' 'xorg-xprop' 'xorg-xrandr' 'xorg-xwininfo' 'yad')
makedepends=('git')
optdepends=(
- 'strace'
- 'zenity'
- 'gamemode'
- 'mangohud'
- 'vkbasalt'
- 'winetricks'
- 'wget: for optional reshade download'
- 'unzip: for optional reshade download'
- 'git: for pulling optional shaders'
- 'xdotool: for playing regular games side-by-side in VR'
- 'xorg-xwininfo: for playing regular games side-by-side in VR'
- 'vr-video-player: for playing regular games side-by-side in VR'
- 'xdg-utils: for opening the ProtonDB URL of started game'
+ 'strace: write a strace log of the launched game'
+ 'gamemode: for using GameMode per game'
+ 'mangohud: for using MangoHUD per game'
+ 'vkbasalt: for using vkBasalt per game'
+ 'winetricks: winetricks support'
+ 'vr-video-player: for playing regular games side-by-side in VR'
+ 'nyrna: for using Nyrna per game'
+ 'replay-sorcery: for using Replay-Sorcery per game'
+ 'net-tools: for optional network monitoring'
+ 'boxtron: for optional Boxtron support'
+ 'scummvm: for optional ScummVM support via Roberta'
+ 'wine: for optional Vortex Mod Manager support'
+ 'gameconqueror: for optional cheating'
+ 'gamescope: for optional GameScope support'
+ 'libnotify: for optional Notifier'
+ 'cabextract: optional for extracting the wmp10 setup archive'
+ 'innoextract: optional for extracting the Cheat Engine setup archive'
+ 'usbutils: optional for a quick VR HMD presence check'
+ 'jq: optional for extracting game names from the steam api and for sorting available Lutris Wine Versions'
+ 'rsync: optional for backing up steamuser files from proton games'
)
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
@@ -46,4 +53,4 @@ package() {
cp -r categories lang misc regs reshadepresets tweaks "$pkgdir/usr/share/stl"
install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
-} \ No newline at end of file
+}