summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2020-12-07 17:02:35 +0300
committerorhun2020-12-07 17:02:35 +0300
commit88bc0a9ce1777c2cd589e4dde9f36afe5bea5e14 (patch)
tree4c440523626b1cd76070b43c1eb0b24ceb62d5b5
parenta7e94170ed0e45f03cc98010fa207d4546c15c99 (diff)
downloadaur-88bc0a9ce1777c2cd589e4dde9f36afe5bea5e14.tar.gz
upgpkg: stegano-git 0.4.1.r8.g46fd3fd-1
Add tests
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 734a4007417c..5469ff4dd6d2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = stegano-git
pkgdesc = CLI tool for steganography. Supports hiding data in PNG images via LSB Encoding. (git)
- pkgver = 0.4.1.r0.g5774494
- pkgrel = 2
+ pkgver = 0.4.1.r8.g46fd3fd
+ pkgrel = 1
url = https://github.com/steganogram/stegano-rs
arch = x86_64
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index e6ee1cb775ab..2d091b6e2a5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# https://github.com/orhun/pkgbuilds
pkgname=stegano-git
-pkgver=0.4.1.r0.g5774494
-pkgrel=2
+pkgver=0.4.1.r8.g46fd3fd
+pkgrel=1
pkgdesc="CLI tool for steganography. Supports hiding data in PNG images via LSB Encoding. (git)"
arch=('x86_64')
url="https://github.com/steganogram/stegano-rs"
@@ -24,6 +24,11 @@ build() {
cargo build --release --locked
}
+check() {
+ cd "${pkgname%-git}-rs/${pkgname%-git}-cli"
+ cargo test --release --locked
+}
+
package() {
cd "${pkgname%-git}-rs"
install -Dm 755 "target/release/${pkgname%-git}" -t "${pkgdir}/usr/bin"