summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOrhun Parmaksız2021-11-16 19:01:11 +0300
committerOrhun Parmaksız2021-11-16 19:01:11 +0300
commit8ca066e67c61437980df694f22ed3f9b16c68b89 (patch)
treebabc265d357b65599e1828c7489e56ee613e53d5
parent1a16becbb0f4e38042e51740ea3d4915ef077881 (diff)
downloadaur-8ca066e67c61437980df694f22ed3f9b16c68b89.tar.gz
upgpkg: stegano-git 0.4.10.r2.g1749b39-1
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d0efef88a6c3..c39800216676 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = stegano-git
pkgdesc = CLI tool for steganography. Supports hiding data in PNG images via LSB Encoding. (git)
- pkgver = 0.4.9.r0.gf8bf0fb
+ pkgver = 0.4.10.r2.g1749b39
pkgrel = 1
url = https://github.com/steganogram/stegano-rs
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index d27abd0102ff..cdfe1d252888 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# https://github.com/orhun/pkgbuilds
pkgname=stegano-git
-pkgver=0.4.9.r0.gf8bf0fb
+pkgver=0.4.10.r2.g1749b39
pkgrel=1
pkgdesc="CLI tool for steganography. Supports hiding data in PNG images via LSB Encoding. (git)"
arch=('x86_64')
@@ -20,14 +20,19 @@ pkgver() {
git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "${pkgname%-git}-rs/${pkgname%-git}-cli"
+ cargo fetch --locked
+}
+
build() {
cd "${pkgname%-git}-rs/${pkgname%-git}-cli"
- cargo build --release --locked
+ cargo build --release --frozen
}
check() {
cd "${pkgname%-git}-rs/${pkgname%-git}-cli"
- cargo test --release --locked
+ cargo test --frozen
}
package() {